Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to rsync a RAID 1 on a system with absolutely nothing running ( i've moved all services to another server ). So it's just me via ssh. For some reason, it's very slow:

cat /proc/mdstat

Personalities : [raid1]
md1 : active raid1 sdc1[1] sda1[0]
      104320 blocks [2/2] [UU]

md2 : active raid1 sdd1[1]
      1953511936 blocks [2/1] [_U]
      bitmap: 10/233 pages [40KB], 4096KB chunk

md0 : active raid1 sdc3[1] sda3[2]
      240814272 blocks [2/1] [_U]
      [>....................]  recovery =  1.0% (2488576/240814272) finish=8243.9min speed=479K/sec
      bitmap: 94/230 pages [376KB], 512KB chunk

unused devices: 

I already tried:

  • Setting /proc/sys/dev/raid/speed_limit_min to a very high value
  • Setting --bitmap=internal

None of these worked.

I also run smartctl on all HDs, no errors were detected. They seem fine. Hdparm also reports an average speed of 4000MB/s for reads. Which seems acceptable.

Any ideas of what might be happening?

I'm running centos 5.5 and my kernel is 2.6.18-274.7.1.el5.028stab095.1.

share|improve this question
    
How big are the disks? What make/model are they? –  Tom O'Connor Dec 31 '11 at 17:45
    
/dev/sda and /dev/sdc are Hitachi Deskstar T7K250 series ( 250GB ). –  Fernando Dec 31 '11 at 18:07
    
I think there were issues with mdadm and CentOS 5.5 (fixed in 5.6) - why did you not upgrade? Current Version is 5.7. –  Nils Dec 31 '11 at 22:12

2 Answers 2

Probably a silly question, but have you verified that the speed_limit_max is also sufficiently high? 4000MB/s would be blindingly fast, that must be the cached speed not the actual disk speed.

share|improve this answer
    
Agreed. My guess is that the maximum is set to 500kbps, which you seem to be hovering near. –  Scrivener Jan 11 '12 at 4:36

md1 is on the same physical device with md0, which is rebuilding. Are you sure there is also no activity on md0 ? Disk access on md1 can be slowing down the resync operation on md0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.