Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Setting up a new CentOS 6 server with Plesk 10.4.4 using Postfix, I am unable to send emails from any user account on port 25, 465, or 587 without having SSL enabled. If I check to use SSL in Apple Mail, on iPhone, or in Outlook, everything works fine. Without, emails will not send and I get errors saying the SMTP server connection failed. I'm using apf and have the ports enabled, and have also disabled the firewall during testing and still have no luck.

On my old CentOS 5 box with Plesk 10.1 this isn't a problem, and I have all users sending email through 587 with user/pass authentication due to most ISPs blocking access to 25. I've seen plenty of articles on what to do if you can send without SSL but not with, however I'm not finding much on the other way around. Any help would be much appreciated!

share|improve this question
    
So what is the question here? –  mailq Jan 1 '12 at 20:54
add comment

2 Answers

It seems that the new version has improved security. Without encryption you are passing user ids and passwords in clear text or a near equivalent. If things work with SSL enabled, you shouldn't have much of a problem.

If you are looking for documentation on how to enable harvesting of your passwords, you likely want to undo some documented steps. Look for documentation on how to enforce SSL on connections. Find where that has been done and remove that configuration. I would not do so or allow an administrator reporting to me to do so.

share|improve this answer
add comment

Find the Postfix main.cf file and set:

smtpd_tls_security_level = may

I have no idea where main.cf might be located in CentOS with Plesk, but the usual location is /etc/postfix/main.cf.

If TLS is being enforced via the Postfix config, smtpd_tls_security_level will be set to encrypt. may makes it optional.

http://www.postfix.org/TLS_README.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.