Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We run a Radius server (Windows Server 2008 R2 running NPS). My goal is to push out GPOs to wireless users with the network information. I am successfully doing this with Windows 7 clients, iOS clients, and Android clients, but Windows XP is throwing fits. I am using Ubiquity UniFi APs: http://www.ubnt.com/unifi

When creating the GPOs for this, I mirrored all of the settings I used for Vista and W7 clients to the settings for my XP clients, but XP will not connect. I am not given any error messages; XP just sits there. I have also tried manually creating a wireless profile on the XP machines, and I can't get them to connect that way either. My XP test client is running SP3. I've tried everything I can think of, and I've tried to find info online.

Any ideas?

share|improve this question
    
Anybody have any suggestions? –  Luke Jan 3 '12 at 15:08
2  
WinXP WPA2 Updated? microsoft.com/download/en/details.aspx?id=1974 –  Chris S Jan 3 '12 at 20:51
    
Have you looked in the event log? There should definitely be errors/warnings there. –  MDMarra Jan 3 '12 at 21:16
    
I can't apply the update because I am already running SP3. When trying to install, it says the service pack I am running is newer than the update. So, I assume that hot fix was part of the service pack. –  Luke Jan 4 '12 at 1:39
    
The event log on the NPS server isn't logging anything. –  Luke Jan 4 '12 at 2:07

2 Answers 2

Turns out it was a problem with the device driver. Windows wasn't showing WPA2 as an option in the wireless setup. I uninstalled the wireless adapter in Device Manager and let Windows recognize and reinstall it. All is well now.

Thanks to all for your help! Luke

share|improve this answer
    
Great to hear you've resolved this. Be sure to mark your answer as "accepted". –  jscott Jan 4 '12 at 2:12

Add the Machine Certificate of the NPS Server to the trusted List, then also XP will join :-) ...or the Certificate you are using in NPS... look it up, you can configure it.

share|improve this answer
2  
Do not post links advertising your site/business in answers. That's what you have a profile for. If you post good answers, people will view it. If you post rubbish that doesn't answer questions (like this), people won't. –  MDMarra Jan 3 '12 at 21:16
    
I unchecked the option to 'validate certificate.' If that is unchecked, I don't need to add the certificate do I? –  Luke Jan 4 '12 at 1:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.