Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am looking to setup WOL on a set of servers. These are Dell PowerEdge R210 servers running Centos 6.0. I searched the BIOS and I couldnt find the WOL option. My power management in BIOS has only

i) CPU Power and Performance Management 
ii) Fan Power and Performance management
iii) Memory Power and Performance Management

In linux :

The output of my ethtool eth1 :

[root@hgcc04 ssubbiah]# ethtool eth1
Settings for eth1:
    Supported ports: [ TP ]
    Supported link modes:   10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full 
                            100baseT/Half 100baseT/Full 
    Advertised pause frame use: No
    Advertised auto-negotiation: Yes
    Speed: Unknown!
    Duplex: Half
    Port: Twisted Pair
    PHYAD: 1
    Transceiver: internal
    Auto-negotiation: on
    MDI-X: Unknown
    Supports Wake-on: g
    Wake-on: d
    Link detected: yes

I can enable the Wake-on magic packet by using "ethtool -s eth1 wol g" but still it doesnt seem to work. Can someone please let me know whether my machine has the capability to work with WOL and how to get it to work?

share|improve this question
Before you attempt to run ethtool -s eth1 wol g, you need to make sure the link is up! "Link detected: no". And if physically checked and correctly plugged in etc, then you need to investigate this before WOL will work... – Cold T Jan 3 '12 at 17:27
Yeah I fixed it, Now it says Link detected to yes. – sethu Jan 3 '12 at 19:02
up vote 4 down vote accepted

Servers are designed to be powered on 24x7, so it's not surprising that they lack BIOS support for WOL. In instances where you need to be able to programmatically power on a server, I typically use IPMI, via a remote management card. HP provides this through their iLO cards, and I suspect that Dell does via their DRAC cards as well, but I don't have personal experience with them.

share|improve this answer
R210 models support WOL. See… using the builtin NICs (page 47) – Cold T Jan 3 '12 at 17:34
Yes IPMI is probably the ideal route as it gives you additional features, but the user did not asks that particular question; so my answer was directed to his specific question. Been a long day for me... – Cold T Jan 3 '12 at 17:40
@ColdT - that's absolutely appropriate. Sometimes I'll intentionally write an answer that doesn't directly address things exactly how the OP wanted, but instead, pushing them towards how I think is a better way of doing things. – EEAA Jan 3 '12 at 17:45

You need to perform a couple steps first. Access the BIOS (F2). Then from there go to Integrated devices and set the NICS to Enabled With PXE. Then go to boot order and place Nic in first slot. After that then reboot and then hit Ctrl-S for the Broadcom Boot agent.

(The message prompting to press is displayed once for each Broadcom NetXtreme Gigabit Ethernet adapter you have in your computer. The messages are displayed in the same order as the assigned adapter device number. )

Within the Boot Agent set the Preboot Wake on Lan to enabled. Hit F4 to save.

share|improve this answer

Once you have 'fixed' the 'Link detected: no" issue, follow the rest:

Halt Linux and shut the system off. The connection LED on the NIC and switch or hub will remain on, indicating the NIC is monitoring the network for wake up packets directed to its MAC address.

Send a Magic Packet wake up signal to the MAC address of the WOL enabled NIC, and the system will boot.
share|improve this answer

Normally I would agree with ErikA's response - with one catch for this particular server.

I remember in the last week of my last job trying to set up an R210 so I could wake it using IPMI.

The server should support it using the onboard BMC, even if you don't have the DRAC.

However after wasting a few hours I gave up - when performing a packet trace I determined the server would respond from the ip address of the BMC with a handful of packets, then for some reason it would stop and I would get a packet back from the actual ip of the server rather than the BMC, then it would stop responding until I tried again with the same story again and again.

I checked my config against a 2900 that was working and couldn't find any difference. Shame as the R210 was our UTM and would have been nice to remotely turn off/back on again and read fault codes if need be.

Also as I'm more of a windows guy, I downloaded Supermicro IPMIview to allow me to use the IPMI capabilities as most people seemed to be talking about linux tools to do so.

If I had more time to spend, I would have spoken to Dell support, but in the end I passed the verdict that if this server was to be remotely powercycled, to get a DRAC.

It is possible I was doing it completely wrong but that doesn't explain why a config that worked on older dell boxes wouldn't work on this one - hoping a f/w update may have fixed it. Alternatively it could have been an incompatbility between the R210 and the Supermicro tool.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.