Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just set up a pptp server on Debian Linux yesterday by following this guide: When I tried to connect to the server using both XP and iOS, the client successfully connects to the PPTP server, however, I can't seem to access the Internet thru the pptp connection. When I tried to capture traffic using tcpdump on just the pptp interface itself, I can see only outgoing traffic and no incoming traffic at all. (Please see image)

Wireshark Capture

share|improve this question
up vote 0 down vote accepted

more than likely, your internet gateway (router?) does not have a route back to your PPTP gateway. So when a packet comes from x.x.x.x (VPN ip-range) the router throws it to the WAN interface instead of back to the PPTP server.

share|improve this answer
Actually both the client and the pptp server are located in the same network. I was able to fix the one way issue. However, I forwarded port 1723 on my router but I can't connect to the pptp server from the internet. Any advice? – David Jan 3 '12 at 19:28
PPTP requires a lot more than just port 1723. You must allow GRE traffic... as well. (GRE is a Protocol... not a port) – TheCompWiz Jan 3 '12 at 21:47
I never get how to allow gre traffic. I have a Linksys wireless router and the only option I see is VPN pptp passthru and that's enabled. – David Jan 6 '12 at 23:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.