Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How does one enable remote listening with rsyslog (on Debian). Forgive what seems like a super basic question, but all the docs I'm finding about it seem to apply to older versions in which one would simply add a -r to the config options. The /etc/default/rsyslog.config tells me that -r is deprecated, but it does not state what the current method is.

I looked at this: How does one enable remote listening with rsyslog which has a comment about -r being deprecrated, but again, no mention what replaces it.

I confirmed that nothing is listening on port 514 on my server at the moment.

(My goal is to log server traffic through an Airport Extreme router.)

Thanks!

share|improve this question
1  
You seem to have read that other question, did you not actually read the answer? –  Zoredache Jan 3 '12 at 19:32
1  
Do not fear the manpage. It will lead you to many glorious victories. –  MDMarra Jan 3 '12 at 19:51
    
Zoredache, I did see it, but I guess I didn't want to believe that a one character flag had been deprecated and in its place, we get 32 characters of configuration. –  Tony Adams Jan 3 '12 at 20:02
    
@MDMarra Sites such as this exist because man pages are generally very poorly written. I can also vouch that rsyslog.com/doc is a mess of obsolete examples with little actual documentation. –  Aaron Copley Jan 3 '12 at 22:50
1  
@AaronCopley except for the fact that the correct answer for this came directly from the manpage. –  MDMarra Jan 4 '12 at 0:04

1 Answer 1

up vote 4 down vote accepted

Have you read the man page for the rsylog.conf (or rsyslog.config) file? It says:

Modules
...
imudp

Input plugin for UDP syslog. Replaces the deprecated -r option. Can be used like this:

$ModLoad imudp
$UDPServerRun 514

...

share|improve this answer
    
Thanks, but when I run: sudo service rsyslog status I get: imudp not found If I put in the path to imudp.so, the only result of "locate imudp", I get Permission denied –  Tony Adams Jan 3 '12 at 20:48
    
And when I chmod +x imudp.so and try to run the service status, I get a seg fault. –  Tony Adams Jan 3 '12 at 21:08
1  
@TonyAdams Please don't go randomly chmod'ing things executable and trying to run them. You will create a very large mess that you have to clean up later. A shared object library (.so file) is not an executable program, and cannot be "run" as if it were one - it must be loaded by applications that know what to do with it. –  voretaq7 Jan 3 '12 at 21:29
1  
You need to spend some time with the rsyslog documentation. Specifically look up the ModLoad directive & note that you can specify full paths to modules (why the module was not found in your installation is another problem that you should take a look at - you may have installation or configuration issues with your copy of rsyslog...) –  voretaq7 Jan 3 '12 at 21:30
    
Thanks. I specified a path using $ModDir and now I'm getting /etc/default/rsyslog 9: /usr/lib/rsyslog/: Permission denied The /usr/lib/rsyslog directory is 755 –  Tony Adams Jan 3 '12 at 22:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.