Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there an easy way to upgrade from one PHP maintenance level to another in Windows (i.e. 5.3.6 to 5.3.8)? Or is the only option to rename my current install folder, and install a fresh copy?

I previously installed PHP using a flat ZIP file (no installer), and since I'm going from one minor-revision to another, I was wondering if I could do a simple file-overwrite (stopping IIS beforehand, of course). There are no .ini file differences between these two releases, and I'd rather not have to jump through all the PEAR hoops to restore the modules I have installed.

The PHP documentation discusses upgrading from a previous release to the current one, but there's no information (that I see) about going from one maintenance level to another, within the same release. Any tips would be appreciated.

share|improve this question

migrated from stackoverflow.com Jan 4 '12 at 2:32

This question came from our site for professional and enthusiast programmers.

2  
Keep a backup of your current folder and try it. –  ridecar2 Jan 3 '12 at 14:46
    
I was hoping someone had already tried that and could report success or failure. Jumping through all the necessary hoops to insure that I've set things up properly (in a scratch PHP environment) is a bother. Being able to simply overwrite would rock, in small update cases like this. –  Jonah Bishop Jan 15 '12 at 1:08
add comment

2 Answers

up vote 0 down vote accepted

For those interested, I just updated a 4.3.8 install in Windows to 4.3.9 by simply overwriting the files. I had to merge a few changes from the 4.3.9 .ini file (a few new sections were added), but upon starting IIS, things seemed to work. I'm not sure I'd try this on a major version change (e.g. 4.3.x to 4.4.x), but for small dot-versions this seemed to work.

If I run into any problems from this update process (I haven't seen any so far), I'll do my best to report them here.

share|improve this answer
add comment

I'm becoming a bigger and bigger fan of the Web Platform Installer from MS. I actually just recently used it again to do the exact update you're mentioning. You'll want to compare your config files of course, as any modules beyond the standard will not be enabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.