Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a IVR set to pickup our PSTN lines and tell the user to enter the extension OR to press 1 for a representative. If the person enters an extension it transfers within 1 second , but if they press 1 asterisk goes silent for 5-10 seconds before it starts ringing the phones in a Hunt group. Below is the pastebin with the Full log while I call in and press 1.

http://pastebin.com/MRD1CFfT

share|improve this question

1 Answer 1

up vote 4 down vote accepted

The system is waiting for further input to determine whether the complete extension is '1' or something else that starts with '1'.

Do you have other extensions in that context that start with the number 1? Check your dialplan.

share|improve this answer
    
crap. Beat me too it. But this. Your system is waiting for a pre-determined time for more input. You need to find where this is enabled and shorten it to 2 seconds or something –  Holocryptic Jan 4 '12 at 21:14
    
Or better, remove the other extensions that start with '1' from that context. If you can. :) –  MikeyB Jan 4 '12 at 21:15
    
@MikeyB Note that even if we use another number like 8 the issue still occurs. Our extensions in the 100 zone. –  Jacob Jan 4 '12 at 21:16
    
The issue will occur regardless of the single digit re-route you're trying to press. Your system is configured to wait for a set amount of time unless 3 digits are pressed. You need to shorten the overall time or the time allowed between button presses to fix this –  Holocryptic Jan 4 '12 at 21:19
    
Do you know what in the Dial plan I need to change? –  Jacob Jan 4 '12 at 22:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.