Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to use the following command to set the default OU for new distribution groups in Exchange 2010:

Set-OrganizationConfig -DistributioNGroupDefaultOU 'corp.company.com/Employees/MailingList' but I am getting the error:

> Cannot process argument transformation on parameter
> 'CustomerFeedbackEnabled'. Cannot convert value "System.String" to
> type "System.Nullable`1[System.Boolean]", parameters of this type only
> accept booleans or numbers, use $true, $false, 1  or 0 instead.
>     + CategoryInfo          : InvalidData: (:) [Set-OrganizationConfig], ParameterBindin...mationException
>     + FullyQualifiedErrorId : ParameterArgumentTransformationError,Set-OrganizationConfig

I saw an online tutorial that suggested this method but it doesn't seem to be working for me. I've tried setting the CustomerFeedbackEnabled param but it just keeps asking for more and more params.

I've also tried specifying the OU in the LDAP 'OU=MailingList,OU=Employees,DC=CORP,DC=COMPANY,DC=COM' format to no avail.

Any suggestions?

share|improve this question
add comment

1 Answer 1

You are trying to do exactly what the article specifies won't work!

You need to pass on the Distinguished Name of the OU for this to work, like this:

Set-OrganizationConfig -DistributionGroupDefaultOU "OU=MailingList,OU=Employees,DC=corp,DC=company,DC=com"

Update: apparently you are not the first to have this issue with parameters passed to the Set-OrganizationConfig cmdlet. If you are using Exchange 2010 RTM, please try and install Exchange 2010 SP1

share|improve this answer
    
Hi Judas, I should have mentioned, I had tried this as well; in fact that format was my first attempt. If you check out the article it also shows a totally different error thrown when you attempt to do it in the form with the back slashes. So I do not think this applies here. –  tacos_tacos_tacos Jan 5 '12 at 0:22
    
I'll install SP1 tonight and see if that helps - it needs to be done anyway –  tacos_tacos_tacos Jan 5 '12 at 16:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.