Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Ubuntu box running in a windows LAN. The Ubuntu box has the following line in /etc/fstab:

//192.168.47.130/Data    /hqserver    cifs            credentials=/etc/cifspw,iocharset=utf8,file_mode=0777,dir_mode=0777     0       0

This has been working just fine for weeks. My purpose for mounting this is to make backups of the windows folder.

However, for some reason this mount was disconnected, or dropped, or something. I no longer have access to the windows share at the linux location /hqserver . I ran the mount -a command and there was no output -- no errors, nothing. I pinged the Windows server at 192.168.47.130 and it is reachable. I did an ls -alF on root and this is the output for the /hqserver location

d?????????   ? ?      ?        ?                ? hqserver/

Then cd into /hqserver and do an ls -alF gives me:

ls: cannot access .: Cannot allocate memory
total 4
d?????????  ? ?    ?       ?                ? ./
drwxr-xr-x 25 root root 4096 2011-12-19 07:01 ../

Any idea what is going on!?

share|improve this question
    
Have you tried unmounting/remounting e.g. with smbmount? –  Andrew Jan 5 '12 at 0:31
    
Have you tried another share on that server or created a new share on another server to see if you are getting the same issue? Also have a look at this as you are not the only one having this issue - us.generation-nt.com/answer/… –  enterzero Jan 5 '12 at 0:42
    
I have tried to unmount and remount. I tried creating a new mount point in /etc/fstab mounting to a new directory (hqserver_2). When I executed sudo mount -a I received the same issue. @enterzero -- It doesn't look like that link works, but I found two other locations that have (I believe) the same information. jlcoady.net/windows/… is one, and a discussion is found here: ubuntuforums.org/showthread.php?t=869994 I can't get onto the Win machine yet, but will try later tonight and post back. Thanks! –  Garfonzo Jan 5 '12 at 3:38
add comment

1 Answer

Fixed!

I followed the instructions on this site (thanks to enterzero). As point out in the discussion linked in the page, the Windows machine needs to be told to act like a file server. I'm glad it worked. If the link goes down, here are the instructions:

  1. Set “HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache” to “1″.
  2. Set “HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size” to “3″.
  3. Restart the “server” service.

Viola!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.