Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have MySQL installed on an Ubuntu machine.

I added this line in /etc/mysql/my.cnf

group_concat_max_len=15360

But there is no effect. Every time I restart mysql, the value is set to 1,024. I have to manually run

SET GLOBAL group_concat_max_len=15360

...every time I start up mysql.

Why is my.cnf not working the way I thought it should? Thank you

share|improve this question

3 Answers 3

up vote 8 down vote accepted

If you have the setting already in my.cnf or my.cfg, and a restart did not bring about the change you expected, you may just have the setting placed in the wrong location.

Make sure the setting is under the [mysqld] group header

[mysqld]
group_concat_max_len=15360

then you can restart mysqld without worry

BTW @gbn may be more correct in this instance because you cannot use commas in the numerical settings for my.cnf (+1 for @gbn)

share|improve this answer
    
I spent hours debugging before I realized my group_concat_max_len was reset. Now I will not have to worry about that happening again. Thanks so much. There was no setting for group_concat_max_len by default in my.cnf, so I just added it to the bottom, under [isamchk]. OOPS. Thanks so much! –  Buttle Butkus Jan 6 '12 at 11:01

Use group_concat_max_len=15360 without the thousands separator

See the docs

If this doesn't persist, then you need to identify the correct my.cnf or my.cfg used by your installation

share|improve this answer
    
Thanks for your comment. Unfortunately, it was my mistake putting the ',' in my question but not in the my.cnf. Rolando actually was right. I had no idea that the location for group_concat_max_len mattered in my.cnf. –  Buttle Butkus Jan 6 '12 at 10:59

Here is what I do:
Open MySQL Workbench and select the connection you want to manipulate if you have more than one, then click Server Administration - Advanced - Various, select group_concat_max_len and set your long desired value.
Remember to restart MySql.
Kind regards, Ola Balstad.

share|improve this answer
1  
That's not setting a permanent setting. –  Dennis Kaarsemaker Mar 23 '13 at 10:24
    
It is permanent!!! Please check before you comment. –  Ola Balstad Mar 24 '13 at 4:55
    
What is mysql workbench? It sounds like your answer applies only to a particular API for MySQL. That's probably why you're getting downvoted. (I didn't downvote you, by the way) –  Buttle Butkus Mar 25 '13 at 2:10
    
MySql Workbench is a useful API tool that comes with the MySQL Community Server when you download it, i.e with the latest version 5.6 –  Ola Balstad Mar 25 '13 at 7:12
    
NB!! Do not get discouraged by my rating. This is a quick and good solution to a common problem. –  Ola Balstad Mar 26 '13 at 8:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.