Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed imagemagick and ffmpeg on my CentOs 5.5 Godaddy VPS.

I have added extension in php.ini also.

I can able to see the installed packages in /usr/local/bin.

But when I print phpinfo(), I am not able to see those. Not event I can use those packages.

Any issue with installation? any help on this?

share|improve this question
    
Have you restarted the webserver? –  fab Jan 5 '12 at 11:16
    
yes I did but no success. –  onkar Jan 5 '12 at 11:55

1 Answer 1

You may need to install the PHP modules that link PHP to those external libraries. For instance on Debian the packages php5-ffmpeg and php5-imagick (here and here for details). If you look at the contents and dependencies for such packages you'll find the include the loadable module (a file with name ending .so) and depend upon the relevant tool/library so if you just install the PHP module the required extras are pulling in too.

The arrangement in CentOS is presumably similar, but the package names probably differ. Try run yum search php to see what php related pacakges are available to be installed.

Also after changing your configuration you may need to manually restart the web server (and/or php processes if you run them seperately as some FCGI setups do) in order for the new modules to be seen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.