Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to synchronize a SQL 2000 SP4 subscriber to a SQL 2008 publisher via a merge pull subscription. When the subscriber tries to run the merge agent, it fails the following error:

The process could not connect to Distributor 'OH05DBS002\SAM_SSG_2008'. SQL Server does not exist or access denied.

Has anyone had success with this setup? I was able to create and synchronize a push subscription so I know that communication works between the two, at least from 2008->2000. The lack of communication from 2000->2008 also affects the ability to create a linked server on the SQL 2000 subscriber. One other tidbit - I did install the SQL 2008 native client on the the 2000 box but it didn't help either.

Before anyone asks, I can't upgrade the subscriber as it still needs to support replication between MS Access 2003. Yeah, I know. :)

TIA,

Brian

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Are you able to use Query Analyzer on the SQL 2000 server to connect to the SQL 2008 server? If that doesn't work nothing else will.

Start with the basics. Is the SQL Browser running on the SQL 2008 server? Can you ping the SQL 2008 server from the SQL 2000 server? Can you access the TCP port that the SQL 2008 instance is listening on?

share|improve this answer
    
It looks like the SQL Browser was part of the problem. This was my first install and I missed checking that service or unchecked by accident. Anyways, I also reviewed the protocols and trimmed them down to just TCP/IP and Named Pipes. After a series of service restarts, changing the linked server entry to just the default SQL Server provider instead of the SQL 2008 Native client, I was able to connect and also synchronize the pull subscription. Thanks for the help! –  Brian Dunzweiler Jul 2 '09 at 13:54
    
No problem, happy to. –  mrdenny Jul 2 '09 at 18:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.