Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I'm setting up a windows deployment server on my network.

share|improve this question
    
Does this happen on every machine you try to PXE boot? –  Mark Henderson Jan 6 '12 at 0:36

1 Answer 1

up vote 2 down vote accepted

Don't forget that you need to open the following ports on the WDS machine:

  • Port 67 (DHCP)
  • Port 69 (TFTP)
  • Port 4011 (PXE)

(Port 67 is still required if your DHCP server is on a different physical machine).

Additionally, I'm not sure if you need to set Option 67 in a simple environment, so for testing sake, I suggest you remove it and put it back if later if you need a more complex environment. I just had a quick look at our DHCP server that we use with PXE booting all the time, and I don't see it set anywhere, only Option 66.


As per your update, your gateway IP address should point to the IP address of your router that connects the segments of your network together. It should be on the same network segment as the IP address that the NIC has been issued.

This is set with the Routers option in DHCP (Option 3 I think).

share|improve this answer
    
Thanks, I actually took down the windows firewall. That means I wouldn't need to open the ports correct? The weird thing is I tested it and when PXE booting from a machine in the same room as the server it works great, when leaving the room and going to another room thats across other switches is when i get the error –  Peter Jan 6 '12 at 3:21
    
@Peter - is it also across subnets? –  Mark Henderson Jan 6 '12 at 3:30
    
I would also suggest that this is the time to set up a SPAN/Mirror port on your switch and watch the network traffic with tcpdump/wireshark etc –  Mark Henderson Jan 6 '12 at 10:26
    
Yes it is across subnets –  Peter Jan 6 '12 at 22:26
    
@Peter - in that case, it's because part of PXE uses the subnet broadcast address, so the routers will need to be configured to pass it on. I'll do some research on it and update my answer. –  Mark Henderson Jan 6 '12 at 22:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.