Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have Linux VPS server 2Gb RAM but when i usee ssh then it is very slow. Sometimes it takes many seconds to see the character typed.

I tried free -m and it says 1670MB free

I tried top command and there is no command having high cpu usage. only sshd is using 0.3% CPU.

share|improve this question
2  
What is the speed of your connection? Your problem may be related to low bandwidth. –  Khaled Jan 6 '12 at 15:19

3 Answers 3

I think your internet line is slow rather than your vps from your remarks.

When you connect with ssh on a slow line (or when you are downloading) you can make the shell lag.

share|improve this answer

Your VPS provider is either capping upload (at least) or is being DDOS'd or flooded to death. I have found that most "cheap" VPS providers have these issues.

share|improve this answer
    
My idea exactly, but I did not want to state it so crude :) –  Lucas Kauffman Jan 6 '12 at 17:21
    
My bad if offensive, sorry. –  Tim Jan 6 '12 at 18:00
    
How can i check that if that is the case –  user825904 Jan 7 '12 at 4:02
    
Try a large SSH transfer to your VPS, that you give you an idea how the connection is. –  Tim Jan 7 '12 at 17:53

As others have said it's very possible it's your home internet.

I have the same problem due to packet loss, at peak times I get between 10-40% packet loss, this makes characters take as long as 5 seconds to appear on my terminal, very frustrating.

Do a ping test at http://pingtest.net/ to check.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.