Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My server: CentOS 5.x, cPanel/WHM, PHP 5.3.6.

I am trying to import a large size of mysql data into a db with phpMyAdmin, the progress is terminated. It says:

enter image description here

Below, it also mentions that:

enter image description here

So it seems that failure dues to php timeout setting. (p.s I don't want to use the mysql spilt dump, don't want to upload time and time again, I just want a single one time dump)

Then I change the max_execution_time value to zero:

enter image description here

Saved and restarted apache and mysql. Then I dropped the db, started the dump in mysql again, still couldn't go through. Same result as before says Script timeout passed. ....

What can I do? What setting should I change to make it happen? (I have root access)

Thanks.

share|improve this question
    
If the database size is large (more than several Megabytes), I recommend you to use command line tools like mysqldump and mysql. They are very much faster and efficient that using phpmyadmin for large DBs export and import. –  Khaled Jan 8 '12 at 13:13
add comment

1 Answer

up vote 1 down vote accepted

Changing max_execution_time and max_input_time in the php.ini file plus modifying $cfg['ExecTimeLimit'] = 0; in config.inc.php for phpMyAdmin should do the trick.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.