Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have forwarded port 80 of my ADSL router modem (DLINK DSL 2640 T) for virtual server 192.168.1.18 which is my server running apache . Problem is typing 192.168.1.18 points to apache webpage on my host but when typing my external ip address something like 59.24.39.59 in browser opens my modem configuration page which can also be accessed by tyaping 192.168.1.1 .

How can I point my external IP given my ISP to my one of my host in my local network ?

Thanks

share|improve this question

3 Answers 3

up vote 3 down vote accepted

A quick Google search tells me that your router may not support NAT reflection (the ability to access local services on your network via an external IP. I don't know whether this is applicable here, but I have often found it useful to disable the routing features on DSL modems (set them to bridge or pass-thru mode) and to install a more robust router between your network and the modem. There are many great router options out there and if you have an old PC with two network cards (I have used a Pentium II 233MHz with 128 MB RAM) you can install a free open source router package (I have used pfSense with much success) which can perform most of the functions of expensive enterprise-grade routers.

share|improve this answer
    
Good point - if the above is the problem, you should be able to access your site externally i.e. from somewhere else using your wan ip, but you won't be able do to so interally. –  Robin Gill Jan 8 '12 at 7:36
    
NAT reflection was the problem tested from my mobile network and it worked thx for saving me from going crazy !! –  Mr Coder Jan 8 '12 at 12:40

Either disable remote administration on the router or change the port it uses.

Problem sounds like it is also using port 80 to serve it's config page and this is getting in there first before your port forward.

share|improve this answer
    
so I changed the router config to port 81 but now I am getting The connection to 59.178.XX.XX was interrupted" when tried to access external ip through google chrome . –  Mr Coder Jan 8 '12 at 6:42
    
Only other things I can think of now is to check your port forward is correctly set with right ip, no other conflicting port forwards, that the one you created was for port 80-TCP or port 80-TCP/UDP rather than just UDP, try a router reboot, and if all else fails, maybe your router will not allow you to port forward port 80 (the router I have to use supplied by my ISP will not allow forwarding port 80 to try and stop people running webservers at home). –  Robin Gill Jan 8 '12 at 7:06

The firmware on this D-Link model appears to be a bit iffy.

First of all: You have to change the internal web-server (the config page) of the router to use a different port-number. Otherwise that gets served first. (It might be enough to just disable "allow access from the internet" to the config pages. I'm not sure about that.)

Second: That D-Link of your doesn't do NAT reflection. In layman's terms: You can't access the outside ip-address from the inside of the router. You can access it just fine from any other computer on the internet. This is a bit of a nuisance but not a show-stopper. It just means that you need to route your traffic (from the inside) so that your router sees it really coming from the outside. You need a proxy for that. It is exactly the same method as used to access web-sites that limit their content to a specific country or region, while you are from a different region. Google for "free proxy BBC iPlayer" and you will get plenty of information how to do this.

Last, but not least: A firmware update on the router may help. These sort of issues are sometimes fixed with an update.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.