Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a Windows Server 2003 R2, which is also our Exchange 2003 server. Perfmon used to work fine on that machine, as it does on our other servers. At some point it stopped working. I'm unable to determine just when because it's not a tool I use regularly.

By "not working" I mean that the red line that normally scrolls left to right just stays on the left hand side and none of the traces are produced. Asking it to record a log also fails, with nothing actually getting recorded. It makes no difference which or how many counters are enabled. To make matters even more difficult, nothing is logged into the Windows event logs.

On and off over the last couple of months I've researched this and learned that it's not too unusual a problem. Unfortunately, solutions are few and far between and nothing I've tried has helped. Following various Microsoft KB articles to recreate the counters from scratch has changed nothing.

Any suggestions? Thanks.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

can you still get counter info? Can you add the counters from that machine on another server or workstation? I'm wondering if the WMI provider has been corrupted somehow.

share|improve this answer
    
The counters are working fine. To be honest I hadn't even given thought to tracing them on another machine. This way I can still see what's happening, even if I don't get this properly solved. Thank you. –  John Gardeniers Jul 2 '09 at 4:32
add comment

This might sound obvious, but you need to "start" the trace. If it stays on the left, or in the middle of an old graph, then this is usually a sign that the trace is not running.

There will be a big red STOP button at the top of the monitor - make sure it is not depressed (or press Control+F). Otherwise, try clicking the button with the picture of the camera on it (Update Data, or Control+U) and see if the graph moves a bit when you click it.

share|improve this answer
    
:) Yes, I did (attempt to) start the trace. –  John Gardeniers Jul 2 '09 at 4:20
add comment

I had a similar issue - sorry I didn't document exactly what process I followed, but I traced it to a permissions issue where the logfiles were being stored.

I ended up giving "Everyone" "Full Control" to the folder where the .blg were saved.

share|improve this answer
    
Thanks. I've just tested that but no luck. Certainly worth a try though. –  John Gardeniers Jul 2 '09 at 22:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.