Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have synced the time of my server to time.nist.gov. This server communicates with a client’s server which is also synced with time.nist.gov.

After noting that we seemed to be out of sync with the time server even after explicit syncing, I set up an hourly batch job to see if my hypothesis is correct and what is our time difference.

I set up the job on Friday and it has already checked the time 50 times. When I first checked on Friday, w32tm utility showed a difference of less than 10 milliseconds. The last check, a couple of hours ago, shows a difference of 20 second.

There have also been 9 cases (in 50 attempts) of error: 0x800705B4 which is a timeout error. The time difference seems to be increasing at the rate of 1 second every hours since Friday, 1/6/2012 5:35 PM EST

I have a Windows Server 2003 Enterprise Edition set up as a VMWare VM, the timezone is EST. Here’s my w32tm and DOS command that log the sync difference:

w32tm /stripchart /computer:time.nist.gov /samples:1 /dataonly >> D:\timedump.txt

Here are the last 4 entries:

Tracking time.nist.gov [192.43.244.18].
Collecting 1 samples.
The current time is 1/8/2012 10:35:00 AM (local time).
10:35:00, +20.3387625s

Tracking time.nist.gov [192.43.244.18].
Collecting 1 samples.
The current time is 1/8/2012 11:35:00 AM (local time).
11:35:00, +20.4854414s

Tracking time.nist.gov [192.43.244.18].
Collecting 1 samples.
The current time is 1/8/2012 12:35:00 PM (local time).
12:35:00, +20.6239407s

Tracking time.nist.gov [129.6.15.28].
Collecting 1 samples.
The current time is 1/8/2012 1:35:00 PM (local time).
13:35:00, error: 0x800705B4
share|improve this question
2  
Time.nist.gov is extremely heavily trafficked. I wouldn't be surprised if it didn't respond to requests on a regular basis (which would cause your error). As a test, can you try syncing to a less hammered source, like one of the NTP.org pools or perhaps your ISP's time service? –  MDMarra Jan 8 '12 at 20:40
    
Sounds reasonable but I got 9 out of 50 timeout errors. the time difference grew when I received successful responses. I still think my server may not be keeping it's time well. –  Abbas Jan 8 '12 at 20:42
    
Is time syncing correctly for the VMware host? –  LukeR Jan 8 '12 at 21:56
    
Glad to know someone else has arrived at the same conclusion. I don't have access to the host, put I have requested the host owners to check its time. –  Abbas Jan 8 '12 at 22:23

2 Answers 2

Your time service is syncing, then the VM host is setting it back to the wrong time.

You either need to get the host's time fixed, or get time synchronization to your VM turned off.

To disable time sync, these settings would need to be added to the .vmx, or via the vSphere Client in the VM's Edit Settings; Options tab -> General -> Configuration Parameters.

tools.syncTime = "0"
time.synchronize.continue = "0"
time.synchronize.restore = "0"
time.synchronize.resume.disk = "0"
time.synchronize.shrink = "0"
time.synchronize.tools.startup = "0"
time.synchronize.resume.host = "0"
share|improve this answer
    
+1 This is sort of correct... He really aught to be syncing a physical clock (the VM Host or other local computer) with an external time source, and having the VM Host set the VM's clock correctly. The VM's clock will never be "reliable" like a physical clock, so the VM will always have troubles with drift (though usually small enough to be negligible). –  Chris S Feb 15 '12 at 16:33

I would say, pick a different time server for both of you to sync if time.nist.gov is sometimes not responding. Secondly, take a gander at this vmware article http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1318 since your time server is virtual, it can tend to drift a bit more than a physical server. I think you're taking the correct steps by syncing with an external NTP server, but also checkout the note about the vmware tools configuration.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.