Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Can't seem to find an answer to this question on AWS' forum, not in the Route53 manual, nor on Stackoverflow/Serverfault in a way that makes sense...and GoDaddy's support sure as heck ain't got an answer:

How do I set an MX record in Route53 for a GoDaddy domain?

My apex record and all CNAME records on Route53 are working correctly, pointing to my app on EC2. But I would love to be able to login to http://login.secureserver.net to check my web-based e-mail for this domain.

In case it's pertinent, GoDaddy's "Email Info Center" for the domain returns...

Domain settings can be invalid if the system cannot verify your email address or if the MX records are incorrect. For additional information, see Managing DNS for your domain names.

Type         Host                          IP Address
Nameserver   ns-AAA.awsdns-47.com          XXX.XXX.XX3.X22
Nameserver   ns-BBB.awsdns-55.net          XXX.XXX.XX5.X86
Nameserver   ns-CCCC.awsdns-24.org         XXX.XXX.XX6.X97
Nameserver   ns-DDDD.awsdns-11.co.uk       XXX.XXX.XX8.92

GoDaddy e-mail server settings listed as...

Server                      Standard Ports             Your Open Ports    
Incoming server (POP3):
pop.secureserver.net        110, 995 (SSL)             110, 995 (SSL)
Outgoing server (SMTP):
smtpout.secureserver.net    80, 3535, 25, 465 (SSL)    80, 3535, 25, 465 (SSL)

In the AWS console for Route53, is it just a matter of creating a MX record set with...

Name  = mail.mydomain.com
Value = 10 pop.secureserver.net 
        20 smtpout.secureserver.net

...???

share|improve this question
2  
Step 1) Migrate your domain to Namecheap, or another Anti-SOPA registrar. –  Tom O'Connor Jan 14 '12 at 11:04

4 Answers 4

It's true, GoDaddy's forum/support/help is rather poor. You always that to Bing or Google it externally to find the right answer but that's true of some other major sites' support pages as well.

Your MX records on any DNS servers will be:

mydomain.com               10 pop.secureserver.net
                           20 smtpout.secureserver.net

Then in your EC2, assuming you are using one to fetch that mail, add the POP3, SPOP3, SMTP, & SSMTP ports to the FW settings.

If you're just using something like Outlook on your local PC and not an EC2 instance, you don't need to fool with FW settings.

Put make sure the clients are configured correctly. Often the default ports and encryption they use have to be adjusted. As I just recently cancelled a GoDaddy account I know they have a correctly configured file to download for you to setup your email client with.

share|improve this answer

To make things nice and clear, as some of the GoDaddy help articles are dead wrong:

enter image description here

You just need to paste the two records from the server settings into your Route 53 control panel as a new record.

enter image description here

The possible deception here is the the GD email panel will tell you you're wrong, but not what is right so you can make it right. Further, their help article tells you do look for the proper MX record settings under the Domains manager, where you'll not find them.

Finally, AWS is a tad confusing since they'll only let you enter a single apex domain MX entry. You can't have two as GD wants and some other zone managers allow, hence the need to double them up.

Hope this helps others! :)

share|improve this answer
up vote 1 down vote accepted

Per AWS' examination, it was clear the MX record was pointing to mail.mydomain.com rather than simply the apex (mydomain.com). GoDaddy's e-mail set-up was likewise seeking mydomain.com...and not a non-existant subdomain. (I had mistakenly added the "mail." prefix in Route53.)

When adding an MX record via the Route53 "Edit Record Set" panel (on the right side of the AWS Management Console), there is no need to input a prefix into the "Name" form field. In other words, particularly if you want your GoDaddy hosted e-mail routed to yourname@yourdomain.com, then simply leave that top/first Route53 form field blank for your new MX record set. The only form field requiring any input is the "Value" section...in which you'd put GoDaddy's e-mail host names and their numeric priority. (In my case: "0 smtp.secureserver.net" and "10 mailstore1.secureserver.net".)

share|improve this answer

pop.secureserver.net and smtpout.secureserver.net are settings for your mail client.

The MX record, on the other hand, tells other mail servers where to send incoming mail for your domain and may be different.

Who is actually hosting your e-mail?

If GoDaddy is hosting your mail, then they should have provided you with a value for your MX record (GoDaddy MX record info). Or look at your old DNS settings to find out what the MX record was.* You can then easily set this in Route53.

Note that the first part (the numbers 10 and 20 in your example) are “priorities” — e.g. if you have more than one incoming mail server which one to use first. Unless you have a fairly complex setup, the numbers you choose won’t really matter much.

* To view your current MX record(s) on Mac/Linux: dig yourdomain.com mx. On Windows: http://technet.microsoft.com/en-us/library/aa998082.aspx.

share|improve this answer
    
Thanks for your help...My e-mail is being hosted at GoDaddy...via m1pismtp01-v01.prod.mesa1.secureserver.net p3pismtp01-v01.prod.phx3.secureserver.net. But GoDaddy asserts no MX Records were found for my domain. I've set Route53 to the correct MX records: 0 smtp.secureserver.net & 10 mailstore1.secureserver.net ...respectively. –  Sean Jan 11 '12 at 0:17
    
Is GoDaddy looking at your new Route53 DNS records (old records may be cached up to the TTL time)? Also, are we talking about the domain that is listed as your web site in your user profile? –  Nate Jan 11 '12 at 1:05
    
No...re. different domain than the one in my profile. That one isn't using Route53. GoDaddy does see the AWS DNS servers on the domain in question. I called them. They're telling me to wait 24-48 hrs to see propagation...but TTL in Route53 is set to just 60...so I suspect something else is going on. –  Sean Jan 11 '12 at 3:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.