Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When we provision users we set the "User must change password at next logon" flag and instruct them to go to OWA to login for the first time and change their password. Using the registry setting ChangeExpiredPasswordEnabled as explained here:

http://technet.microsoft.com/en-us/library/bb684904.aspx

worked well prior to SP2 installation. This allows users with 'expired' passwords to logon and forces a password change before they can access OWA. We just installed Exchange 2010 Service Pack 2 and now it's no longer working. Users with this flag set ('expired' passwords) can't login in at all unless we clear the flag.

FYI here's the registry key configuration as set now with SP2 installed: enter image description here

Any suggestions as to how I might fix this? Or did MS break this feature in Service Pack 2?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

The problem in my case was a trailing space character on the registry key, likely due to a copy-paste from the web, ie. I had:

'ChangeExpiredPasswordEnabled '

vs.

'ChangeExpiredPasswordEnabled'

and thus the setting was not detected. Removing the trailing space character resolved the issue.

share|improve this answer

I found found that this works.

Log on to the Client Access Server
Click on Start, Run and type in regedit and click on OK
Expand HKEY_LOCAL_Machine
Expand System
Expand CurrentControlSet
Expand Services
Click on MSExchange OWA
Right-click on the right hand side pane, click on New  and then DWORD (32 bit) value
Let’s name the key ChangeExpiredPasswordEnabled and its value will be 1, 

Referance is here

share|improve this answer
    
Thanks, but as I explained above, this is what we used successfully prior to the SP2 upgrade. The registry key is still there, but it is having no effect in SP2. –  JJ. Jan 11 '12 at 6:25
    
Have tou checked to see if the red key is still there after sp2 it MIG have removed it. –  t1nt1n Jan 11 '12 at 6:43
    
Do you mean registry key? Yes it is still there following the upgrade - I have checked. –  JJ. Jan 11 '12 at 12:35
    
FYI I posted a screenshot of my registry setting above. –  JJ. Jan 11 '12 at 13:37

I have configured Exchange 2010 SP2 for OWA with ChangeExpiredPasswordEndbled set to 1 , restarted IIS with IISreset , The prompt to change the expried password shows up but it will not change the password. Same as the problem above.

Solution: In my case uninstalling or disabling our antivirus software resolved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.