Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have some problemes with apache on CENTOS...

When I reboot the system, httpd won't start

I have to execut my-self "service httpd start"

chkconfig  httpd --list
httpd           0:off   1:off   2:on    3:on    4:on    5:on    6:off

Any ideas ?

Thank you!

share|improve this question

migrated from stackoverflow.com Jan 11 '12 at 9:56

This question came from our site for professional and enthusiast programmers.

    
What run level are you running in? Based upon that output of chkconfig it looks like it should be starting the service if you're in run level 2, 3, 4 or 5. –  DaveG Sep 28 '12 at 11:32

1 Answer 1

Open a terminal window an enter the following:

/etc/init.d/httpd start

This will start apache

then

tail /var/log/httpd/error_log

This will give you the last 10 entries in the apache log. There, you should find the error. Get it and paste it here.

share|improve this answer
    
I got [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) [notice] Digest: generating secret for digest authentication ... [notice] Digest: done [notice] Apache/2.2.3 (CentOS) configured -- resuming normal operations –  Michael Vendi Jan 11 '12 at 5:50
    
He's already stated that he has to execute a service httpd start - that has the same effect as /etc/init.d/httpd start. –  DaveG Sep 28 '12 at 11:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.