Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to bind the remote desktop listener to 127.0.0.1 on Windows Server 2003 Enterprise.

I tried tscc.msc but it only lets you choose a certain physical adapter.

Also by quickly glancing over HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp I couldn't find any setting that seemed to do the trick.

Is this impossible after all?

share|improve this question
    
The answer to this question would be really useful when using Bitvise WinSSHD. –  djangofan Jan 20 '12 at 0:20
add comment

4 Answers 4

Why would you want to only have it listen on 127.0.0.1? That would make you take over your own session which would then lock the machine.

I'm not sure if you can bind RDP to listen on only IP. I would imagine that you can't. You best option will probably be using Windows firewall to prevent access to port 3389 on all IPs other than 127.0.0.1.

share|improve this answer
    
I agree. Why would you access RDP from the machine itself? Makes no sense to me. But maybe there is a hidden agenda. –  splattne Jul 2 '09 at 8:09
    
Yeap does not make sense to remote desktop to one's own machine. Might as well shut down the service altogether. –  icelava Jul 9 '09 at 1:27
add comment

Binding the RDP listeners to localhost can also be a cheap way to enable multiple concurrent sessions stemming from a single console session.

I'm guessing you want the localhost functionality, not strictly wanting 127.0.0.1. I'm also guessing that you don't want to expose the adapter to the network.

If you're still wanting to do this, I can think of the below method:

  1. Install a local loopback network adapter. (See here.)
  2. Configure the RDP Listener to bind only on the loopback network adapter. In Server2K8 and higher, this will be possible via the tsconfig.msc snap-in. I've never tried in Server2k3 but that should be a similar procedure. (I can go in more details about the configuring the registry if needed.)

From there, you'll be able to RDP to the loopback adapter using its link-local address.

share|improve this answer
add comment

I was able to resolve my issue by doing the following: Start, Run, MMC

MMC: add Terminal Server Configuration

Enable RDP_TCP

Right on The RDP-TCP

Click on Properties

Click on the Network Adapter Tab

Bind the new Vmware Adapter

share|improve this answer
add comment

binding to localhost is very common for several services under linux. so you can ssh to the box and forward ports to your ManagementClient.

The reason is simple: security.

I'm not using windows server, so I have no idea to configure this service. But blocking via windows firewall sound good.

EDIT:

Here is a link how this can be done: www-css.fnal.gov/csi/win-firewall/win-firewall.html

share|improve this answer
1  
Doing ssh and port forwarding to a windows host is very uncommon. –  radius Jul 2 '09 at 7:59
    
Yet this is what I'm doing. I already have the firewall allowing only connections on 127.0.0.1. I just wanted another layer of security by completely removing the listener from every other IP address. –  DominiQ Jul 2 '09 at 8:03
    
If you want RDP to listen only on 127.0.0.1, why not simply not allow RDP to run on the server, or change the TCP port that RDP runs on. What's the end result that you are looking for? RDP (especially on Windows 2008) is already encrypted via a certificate and can be configured to only accept connections which support this higher level of protection. –  mrdenny Jul 2 '09 at 8:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.