Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a SmoothWall Express box that is currently configured with a Green and Purple interface. Both interfaces are in the same /24 subnet (which seems odd to me). The green interface (address of .254) has a DHCP server that is pushing addresses from .1 to .100 and the purple interface (.253) is pushing addresses from .101 to .120. Every machine here is trusted, and as such is connected to the green interface via a wired connection or wireless APs. Nothing is connected at all (port is physically empty, traffic graphs show no activity) to the purple interface. However, every machine here is pulling addresses from the purple interface. So the question boils down to, how do I remove/stop my machines from pulling from the purple dhcp interface? Also, shouldn't the purple interface (if we were using it for guest Wifi or something) be on a different subnet (i.e. 192.168.100.0/24 instead of 192.168.1.0/24 with all the trusted machines)?

share|improve this question
    
Almost a full day and nobody even has a question or suggestion? I'm not sure what to make of that.... –  Timbermar Jan 12 '12 at 13:20
1  
Your question seems to be very specific, maybe it is better to get support from your vendor or hire a consultant. –  Lucas Kauffman Jan 12 '12 at 13:34
    
I was kind of dreading that, I was hoping it was just something simple I was overlooking because I am new to these Smoothwalls. I'm going to try rewording the question, I don't think its really that specific, I just added to much detail. –  Timbermar Jan 12 '12 at 13:54
1  
It sounds like your interfaces are bridged and the DHCP service on the purple interface is „faster” to serve DHCP queries. But this is just a guess, I do not have any hands-on experience with SmoothWall Express and could not find any bridging functionality in the free version. –  lgarzo May 31 '12 at 17:51

2 Answers 2

Keeping untrusted devices (i.e. guest wifi) separate from a trusted network is advised and putting them in a different sub-net would achieve this.

From what I understand, your devices are being assigned addresses from the DHCP server running on your purple interface (.253) and you'd prefer them to take addresses from the green interface (.254).

All your devices are connected to the green interface via a physical cable.

Now, I'm not an expert on Smoothwall, I've been tinkering with it for a few months now myself but I'm willing to try and help.

I'm not sure why they're taking addresses assigned by the purple interface. It sounds like they're actually just connected to the purple interface but, assuming this is not the case, can you try switching the addresses?

The purple interface would take on .254 and the green interface would take on .253

If the devices are just searching for a DHCP server and they take on the first one they come accross (.253 which is purple) then this might be the cause?

share|improve this answer
    
I'm not at that site anymore, and given the holiday, neither is anybody else, I won't be able to do any looking into this until tuesday. However I did attempt to move the purple interface to a different subnet and all traffic stopped flowing on the spot, and I was not able to get a new IP. My first thought was that the interfaces were switched, however the traffic graphs consistently show all traffic on green. I'm kind of at wits end on this one, not that I had much wits with smoothwalls to start... –  Timbermar Jan 16 '12 at 1:56

simplest way would be to login to SW box (https://IP.Add.Re.ss:441) on port 441 and turn DHCP OFF, on your 'purple' nic. If you are using Red, Green and Purple, I think you've set up the SW router to have your AP's connected to the separate nic 'purple'. Again, easiest, if you're not using it is to 'turn it off'.

Again, login > Networking (tab) > Interfaces > 'Purple' interface > (pull down)

-or-

Services (tab) > dhcp > select 'Purple' interface (pulldown) > 'disable' (uncheck enable)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.