Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

There is one client machine that has processing issues. I can't find driver updates that look like they fix this.

And we have other machines with similar software setups that are working fine. (Windows XP SP3)

I can duplicate the issue by doing the following. Open any program that hasn't been opened in a while (so it's not in memory anywhere, for example Photoshop)

What happens is that all other processing on the machine slows to a crawl. And the application takes a long time to open. (same with the bootup time for the machine, it's abnormally long)

And working with the application is very unresponsive for a few minutes.

The funny thing is that you can listen to the computer process when you have music on (any program) since the music stops and stutters in line with the processing the computer is doing.

We have Sophos as the virus scanner and we have tried defragging the machine with jkdefrag, cleaning up and temp files, deleting any unused programs and dust cleaning the computer.

I don't wanna format just yet if it's something known.

Update:

Turning off the Sophos services did nothing.

I tried perfmon and what happens is I get spikes on Pages/sec and Disk queue length where disc queue length stays well over 100% for the whole time and Pages/sec goes well over that.

I'm going to look at the Dell diagnostics next.

share|improve this question
    
Please comment on why you downvote. –  Ólafur Waage Jul 2 '09 at 17:19
    
Your question/problem is not sysadmin related. –  Joe Jul 2 '09 at 19:56
    
The FAQ states that this is a site: "If you are in charge of many desktop PCs (other than your own)." And we have many of these machines here and it's not my own. –  Ólafur Waage Jul 2 '09 at 21:06

5 Answers 5

We use a very similar setup here both with the optiplex, sp3 and Sophos, and more often than not find that the Sophos on access scanner is the one causing the problem. Try turning it off temporarily to see if that makes the difference? If it does, then reinstall it and it seems to be fine for a few months.

We tend to find that machines with Abobe products and machines with large PST's seem to suffer the most from this issue.

share|improve this answer
    
I've turned off all the Sophos services, we'll see if it behaves now. Thanks. –  Ólafur Waage Jul 2 '09 at 9:28

Have you used System Monitor (perfmon) to assess CPU, RAM, and disk usage?

Does this problem happen in Safe Mode as well?

share|improve this answer

I'd start by running the Dell diagnostics (all of them) if you still have the diagnostic partition installed. I've found that they do a decent job of identifying hardware problems if they exist.

share|improve this answer
    
and if you have to call into dell support for a replacement (if under warranty), they'll make you run these anyway. running them beforehand will save time on the phone. –  brad.lane Jul 2 '09 at 17:43

From experience, sounds very much like a crashing hard drive.

share|improve this answer

Bad sectors on an IDE or SATA disk, retrying quietly in the background and eventually succeeding, can cause this. Defrag does not necessarily fix this.

Actually, several kinds of harware problems can cause this.

Try binary swaps with an identical good known working machine until the problem moves to the other machine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.