Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are using Excel 2010 and sometimes users are working from a network share. When a user on the network opens the file in Excel, the file is locked for editing - this is the expected behavior. When another user tries to open the file, Excel gives the message

[filename] is locked for editing by 'John Doe'

The problem is, the user is always this one particular user's name, no matter who actually has the file open. Where does Excel get this info, and how do I fix it?

Update: I should have mentioned that in Excel, under Options (General), the correct user names have been set up. That is not where this user name is coming from.

share|improve this question

3 Answers 3

up vote 8 down vote accepted

Excel creates a hidden file on the share called ~$filename where filename is the original file. That hidden file conatins the name of the user who has the file locked. The name comes from the Office options, as others have stated.

For some reason that file was not deleted properly when the file was closed. Oddly, everything still works - the next user to open the file can still edit and save, but it looks like it's checked out to someone else. And even after editing, saving and closing Excel, that hidden file is still not deleted.

After manually deleting the file, everything works properly again.

share|improve this answer

Change the name in Excel for the users to be the actual users name under file>options>general

share|improve this answer
    
That has already been done. This is not the issue. –  ScottStonehouse Jan 12 '12 at 18:11
    
Excel gets the name frm that field. John doe is the person that has teh file locked. Are you sure they are not using multiple copies of the same file? –  Jim B Jan 12 '12 at 18:48

Same issue here. the user name does not reside in excel, but word in office 2010: open MS word, options > general fill in the name as needed

share|improve this answer
1  
Um, no. Just wrong. –  HopelessN00b Aug 25 '12 at 5:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.