Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

im using go daddy vps , installed mysql configured /etc/my.cnf to look like this:

[mysqld]
user=mysql
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
port=3306
# bind-address=1xx.1xx.1xx.148
bind-address=1xx.1xx.1xx.148
skip-networking

# Default to using old password format for compatibility with mysql 3.x
# clients (those using the mysqlclient10 compatibility package).
old_passwords=1

# Disabling symbolic-links is recommended to prevent assorted security risks;
# to do so, uncomment this line:
# symbolic-links=0

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

then when i see in /var/log/mysql.log i see the mysql started right :

120113 03:58:59  mysqld started
120113  3:58:59 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
120113  3:58:59 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
120113  3:58:59  InnoDB: Started; log sequence number 0 43665
120113  3:58:59 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.0.77'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  Source distribution

but when i do :

/usr/sbin/lsof -i:3306

i dont see any thing. when i do :

 netstat -a |grep LISTEN

tcp        0      0 localhost.localdomain:smtp  *:*                         LISTEN
tcp        0      0 *:http                      *:*                         LISTEN
tcp        0      0 *:ssh                       *:*                         LISTEN
tcp        0      0 *:https                     *:*                         LISTEN
unix  2      [ ACC ]     STREAM     LISTENING     244331015 /var/run/saslauthd/mux
unix  2      [ ACC ]     STREAM     LISTENING     247310795 /var/lib/mysql/mysql.sock

so i see somekind of mysql socked listen ... but when i try to connect from my Toad to the remote server im getting :
Unable to connect to any of the specified MySQL hosts.

im connecting to the mysql root user . to my application db in port 3306. also i found in the net allot of post saying to remove the skip-networking. but when i do so . im getting this error when i try to start the Db :

120113 14:46:36  mysqld started
120113 14:46:36 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
120113 14:46:36 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
120113 14:46:36  InnoDB: Started; log sequence number 0 43665
120113 14:46:36 [ERROR] Can't start server: Bind on TCP/IP port: Cannot assign requested address
120113 14:46:36 [ERROR] Do you already have another mysqld server running on port: 3306 ?
120113 14:46:36 [ERROR] Aborting

120113 14:46:36  InnoDB: Starting shutdown...
120113 14:46:37  InnoDB: Shutdown completed; log sequence number 0 43665
120113 14:46:37 [Note] /usr/libexec/mysqld: Shutdown complete

120113 14:46:37  mysqld ended

and i do not have any mysql runnning on this port or any mysql running at all ..
what is wrong here ?

share|improve this question
    
FYI, godaddy has been supporting SOPA. –  Tim Jan 13 '12 at 14:17
add comment

1 Answer

What do you think skip-networking means? Remove this statement and it should work. See here for the explanation.

share|improve this answer
    
when i disable / comment this param im getting : 120113 14:46:36 InnoDB: Started; log sequence number 0 43665 120113 14:46:36 [ERROR] Can't start server: Bind on TCP/IP port: Cannot assign requested address 120113 14:46:36 [ERROR] Do you already have another mysqld server running on port: 3306 ? 120113 14:46:36 [ERROR] Aborting and there is no more mysql running in my server –  user61104 Jan 13 '12 at 21:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.