Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are running WSS 3.0 SP2 on Windows Server 2003 R2 x64. We had recently upgraded our Sophos Endpoint Protection from version 9.7 to 10.0. Immediately, our alerts stopped working (although it wasn't noticed immediately). When you tried to create a new alert on a library the page would just hang once you pressed Ok. No workflows that used email would complete. (See http://community.sophos.com/t5/Sophos-Endpoint-Security-and/sophos-10-and-sharepoint-2007/td-p/20119) None of the fixes mentioned in that post worked for us, so we uninstalled Sophos 10 and reinstalled 9.7 which immediately allowed new alerts to flow.

My question is... are all of the alerts that were blocked by Sophos gone forever, or are they queued somewhere that we just need to kick some process to send? I've tried restarting the server, restarting the timer service, clearing the config cache... I'm not sure where else to look. Any tips appreciated!

EDIT: Workflow emails apparently did queue and send. Alerts did not though.

share|improve this question
    
Did you contact sophos support and ask them after explaining what happened? –  Bart Silverstrim Jan 13 '12 at 13:52
    
If they are queued (or lost) and you find out from support it would be good to have it posted as an answer here for reference. –  Bart Silverstrim Jan 13 '12 at 13:52
    
I emailed Sophos to let them know that there is an issue with WSS & Endpoint v10 (although they are probably already aware from the forum post). I doubt Sophos has the alerts anywhere, I'm hoping Sharepoint has them queued somewhere. –  Dan Jan 13 '12 at 14:01

1 Answer 1

up vote 1 down vote accepted

Probably so. Sharepoint doesn't queue up mail, the sending application (sharepoint) would have to send it to a relay off of something that would queue it. The only way it would resend is if the actual mail creation job failed to start (and it sounds like that isn't the case)

share|improve this answer
    
Well, when it wasn't working I had run a packet capture and nothing was being sent across the wire. So either it was getting blocked at the network level or never even started. I'm thinking they're gone as well :( –  Dan Jan 13 '12 at 15:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.