Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since a few hours the fw_conntrack plugin in munin gives always timeout error.

enter image description here

It looks like the timeout is just because it took too much time to process, as it had happened a few times before in the graph. Is it normal that this plugin take more than 10 seconds to finish? There is a Varnish which proxies http request to a nginx.

share|improve this question
up vote 1 down vote accepted

In a test:

jcisio@cecile:~$ time sudo cat /proc/net/nf_conntrack | wc -l

real    0m13.165s
user    0m0.008s
sys 0m13.129s

It takes 13 seconds just to count the number of lines in this file. So munin could not do better. I have to increase the timeout limit.

share|improve this answer
How do you increase the timeout limit? Your answer would be more useful if you added that. – Ariel Sep 29 '14 at 0:02
Check the timeout option in munin-node.conf. – jcisio Oct 4 '14 at 20:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.