Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed several guides to set up samba sharing on our domain. I've got it working where I can join the domain, list the shares, and connect to the samba share from windows. When I connect from windows, I am dumped into the user home directory and can read/write.

I'm trying now to create a new separate share on Samba to use via windows. I created the folder, added it to smb.conf, but can not access the share from windows no matter what. smb.log has zero info nor messages or any log under /var/log/samba. When I try to connect to the new share from windows in Explorer, I am prompted for username password and upon entering am just met with the un/pw prompt again. Via cmd net use, I get an error stating the password is invalid: "The password is invalid for domain/user".

smb.conf

[global]
workgroup = MYDOMAIN
netbios name = samba
server string = Samba Server 3.0
security = ads
realm = MYDOMAIN.LOCAL
password server = 192.168.1.11
encrypt passwords = yes
printcap name = /etc/printcap
load printers = no
printing = cups
log file = /var/log/samba/%m.log
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
local master = no
domain master = no
preferred master = no
dns proxy = no
#============================ Share Definitions ==============================
[homes]
comment = Home Directories
browseable = no
writable = yes
valid users = %S
create mode = 0664
directory mode = 0775
[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes 

[newShare] 
comment = NewShare Share 
path = /home/share/newShare/ 
valid users = @"MYDOMAIN.LOCAL\Domain Users"
public = no 
writable = yes 
printable = no 
create mask = 0765

It's likely I don't have permissions set right on the directory I created; ownership is root:root and 0755, but I didn't see any good examples of how it should be in the millions of tutorials I looked through. However, I'm not sure that would cause the invalid password error.

smb.log:

[2012/01/13 11:06:42, 0] smbd/server.c:main(958)
  smbd version 3.0.33-3.29.el5_7.4 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2008
[2012/01/13 11:14:22, 0] smbd/server.c:main(958)
  smbd version 3.0.33-3.29.el5_7.4 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2008
[2012/01/13 11:29:26, 0] smbd/server.c:main(958)
  smbd version 3.0.33-3.29.el5_7.4 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2008

[not helpful]

I'm not sure at this point where to try and look for the problem.

Oh, I also messed with selinux stuff as a result of find here on SF. It didn't break anything, but it didn't fix anything either. [chcon and semanage fcontext stuff]

share|improve this question
    
You sure that getent group returns MYDOMAIN.LOCAL\Domain Users? –  Hubert Kario Jan 16 '12 at 17:46

1 Answer 1

up vote 0 down vote accepted

After much tinkering, I was able to get it to work. I'm not sure the exact constellation of changes that got things working, but I think it was at least in part due to upgrading samba to 3.4.

Some things:

make sure clocks are in sync;

allowed users = @"DOMAIN+Domain Users"

setting WINS helped; name resolution is important

log level = 2

OH! and after upgrading samba, winbindd seemed to have disappeared... needed to reinstall

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.