Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 servers I am setting up. They are both Windows Server 2008 R2. They are both getting IIS setup as web servers. I have set up other servers that we currently have in production. I did the setup the same way, and did the security certificates and keyed them right.

The old servers I setup, as soon as I add the intermediary certificates, and the security certificate, the address https://myurl.com works just fine. This is assuming I have done port forwarding and opened up the firewall on the server.

So my question is did I miss something that causes these other servers to work for http but anything across https gives the browser the message 501 Not Implemented the request method is not implemented by this server.

I have done side by side comparisons of servers, roles, features, and config files to determine what is different. Everything matches, and the website stuff is a copy of the working stuff, the only difference is the url is different.

share|improve this question
add comment

2 Answers

You have to go into the site bindings for each site that you want to enable SSL on and bind https to whatever IP your site runs on.

enter image description here

share|improve this answer
    
Yes this I know, and it is done. At this point my other servers were able to serve the URL in https, but for some reason the same process gets me error 501 Not Implemented now –  Benjamin Jan 13 '12 at 18:03
add comment
up vote 0 down vote accepted

Okay so I finally found my solution. It turns out, in my port forwarding, there is an enabled check-box on enabling the rule you just added, having missed that on this one 80 was some how enabled while 443 wasn't. It turns out every thing was set up, but one little check-box was missed in the router settings.

share|improve this answer
    
IOW, the issue was not an IIS issue, but rather was a firewall config issue? –  samsmith Jan 16 '12 at 19:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.