Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

just installed a fresh centos-minimal and i can not get bridged network to work or any of the networks not even in host-only mode. when you run ifconfig there is no eth0 only a lo,

also when you cat /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE="eth0"
HWADDR="08:00:27:FE:D5:10"
NM_CONTROLLED="yes"
ONBOOT="no"
share|improve this question
    
Did you try using ifconfig -a instead of ifconfig? The former will display information about adapters that aren't in the 'UP' state. –  nearora May 31 '12 at 3:50

3 Answers 3

up vote 14 down vote accepted

As cpuguru said, you need to config the network. So login on your centos and execute:

vi /etc/sysconfig/network-scripts/ifcfg-eth0

As Chris R explained, you should edit the contents of that file to end up having this:

DEVICE="eth0"
HWADDR=MAC Address*System MAC*
NM_CONTROLLED="no"
ONBOOT="yes"
BOOTPROTO="dhcp"

Then save (escape :wq INTRO) and then reboot:

reboot
share|improve this answer
4  
If you have cloned a VM or otherwise changed the MAC you may need to delete /etc/udev/rules.d/70-persistent-net.rules ... please correct me if I am wrong! –  KCD Aug 8 '12 at 6:41

I had a similar issue with CentOS on Hyper-V the other day.

The solution seemed to be to fire up a terminal, su to root and run 'system-config-network' to enable CentOS to use the virtual nic.

share|improve this answer
    
retuned Command not found. –  Chris R Jan 15 '12 at 1:29
    
This is where I found the command: centos.org/docs/5/html/Deployment_Guide-en-US/… –  cpuguru Jan 15 '12 at 1:32
    
I am using centos 6 i got eth0 to show in ifconfig but it has no IPs or anything. –  Chris R Jan 15 '12 at 1:38
    
Try changing your ifcfg-eth0 script parameter from ONBOOT="no" to ONBOOT="yes" –  cpuguru Jan 15 '12 at 1:43
    
Thank you had to change my ifcfg-eth0 script to DEVICE="eth0" HWADDR=MAC AddressSystem MAC NM_CONTROLLED="no" ONBOOT="yes" BOOTPROTO="dhcp" –  Chris R Jan 15 '12 at 1:50
  1. bridged adapter = connect with already connected internet device
  2. nat

and run..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.