Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm installing Apache on CentOS 5.7, I followed instructions here :

I've installed this also :

Remi Dependency on CentOS 5 and Red Hat (RHEL) 5 ##

rpm -Uvh

When I install this, there's warning:

/var/tmp/rpm-xfer.Bqu2xo: Header V3 DSA signature: NOKEY, key ID 217521f6

But it says that the package is alread installed.

Then I move on to 3rd steps:

yum --enablerepo=remi install httpd php php-common

But it says:

error getting repository data for remi, repository not found.

Why is it like that?

share|improve this question
have you set enabled=1 switch in /etc/yum.repos.d/remi_repofile.repo ? – kaji Jan 16 '12 at 8:12

You need to install both these:

## Remi Dependency on CentOS 5 and Red Hat (RHEL) 5 ##
rpm -Uvh

## CentOS 5 and Red Hat (RHEL) 5 ## 
rpm -Uvh

To get rid of the NOKEY warning when installing the EPEL repo, do this:

rpm --import to import the EPEL GPG key (Taken here)

My guess is that you forgot to install the second RPM for Remi on CentOS 5, which is why it can't find it.

If you want to confirm it's been installed, look in /etc/yum.repos.d and look for a file for remi, than cat it. You should see a section called [remi] in it. Contrary to what kaji said, you do not need to enable it if you do it as a one-time shot with the --enablerepo=remi option...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.