Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Can you route a IP (/32) from one vlan to another vlan in the same vrf of the same router ?

Exemple:

example_router#show version
Cisco IOS Software, c7600s72033_rp Software (c7600s72033_rp-ADVIPSERVICESK9-M), Version 12.2(33)SRD6, RELEASE SOFTWARE (fc3)

example_router(config)#ip route vrf EXAMPLE 10.10.10.3 255.255.255.255 vlan 2706
% For VPN or topology routes, must specify a next hop IP address if not a point-to-point interface
example_router(config)#
example_router(config)#ip route vrf EXAMPLE 10.10.10.3 255.255.255.255 vlan 2706 10.10.20.1
%Invalid next hop address (it's this router)

example_router#sh run in vlan 2705
Building configuration...

Current configuration : 339 bytes
!
interface Vlan2705
 ip vrf forwarding EXAMPLE
 ip address 10.10.10.1 255.255.255.0
 ip helper-address 10.0.0.1
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 no clns route-cache
end

example_router#sh run in vlan 2706
Building configuration...

Current configuration : 339 bytes
!
interface Vlan2706
 ip vrf forwarding EXAMPLE
 ip address 10.10.20.1 255.255.255.0
 ip helper-address 10.0.0.1
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 no clns route-cache
end

vrf config (requested by @rnxrx):

example_router#show vrf EXAMPLE
    Name                             Default RD         Protocols   Interfaces
    EXAMPLE                          xxxxxx:yyyyyy      ipv4        Vl2705
                                                                    Vl2706
[output removed]

example_router#show running-config vrf EXAMPLE
Building configuration...

Current configuration : 7992 bytes
ip vrf EXAMPLE
 description mpls_vpn_EXAMPLE
 rd xxxxxx:yyyyyy
 route-target export xxxxxx:zzzzzz
 route-target import xxxxxx:yyyyyy
!
    [output removed]

!
router bgp xxxxxx
 !
 address-family ipv4 vrf EXAMPLE
  no synchronization
  redistribute connected
 exit-address-family
!
end

I need to break an old vlan in 2, and 1 equipment needs to be on the second vlan, I need to temporary make it run until a client can remotely connect to change it's IP address.

If not, the only option I see is to syncronize with the client and configure the subnet (10.10.10.1/24 in exemple) on the second vlan for a few minutes.

Thank you

share|improve this question
    
Could you please post the physical interfaces configurations with their description? –  petrus Jan 16 '12 at 12:15
    
@petrus - Both vlan's are on the same physical interface, where an GPON/OLT is connected via trunk. –  Radu Maris Jan 16 '12 at 15:02

1 Answer 1

Yes - this is valid, and actually pretty common. The router will treat these interfaces (and associated routes) as being part of a common routing/forwarding table which will be kept separate from any others (unless you manually cross-import).

share|improve this answer
    
Thank you, can you give an example of command to route them, if you look at the example I gave, the commands I tried failed (as a workaround I used just one vlan and raised both IP classes on it until all clients have changed their IP and them break them in 2 again :) ). –  Radu Maris May 24 '12 at 9:10
    
Do you have a global definition of the vrf elsewhere in the config? –  rnxrx May 24 '12 at 15:58
    
Yes, I have updated the example. –  Radu Maris May 25 '12 at 7:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.