Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

If I change the enable32BitAppOnWin64 option on one pool all other pools will change their enable32BitAppOnWin64 option to the same value as the changed one.

I guess this behavior isn't by design. What could be wrong with my IIS ?

Windows Server 2008 R2 IIS 7.5

<applicationPools>
            <add name="DefaultAppPool" />
            <add name="Classic .NET AppPool" managedPipelineMode="Classic" />
            <add name="ASP.NET v4.0" managedRuntimeVersion="v4.0" />
            <add name="ASP.NET v4.0 Classic" managedRuntimeVersion="v4.0" managedPipelineMode="Classic" />
            <add name="SharePoint Web Services Root" autoStart="true" managedPipelineMode="Integrated">
                <processModel identityType="LocalService" idleTimeout="00:00:00" pingingEnabled="true" />
                <recycling logEventOnRecycle="Time, Requests, Schedule, Memory, IsapiUnhealthy, OnDemand, ConfigChange, PrivateMemory">
                    <periodicRestart time="00:00:00">
                        <schedule>
                            <clear />
                        </schedule>
                    </periodicRestart>
                </recycling>
            </add>
            <add name="SecurityTokenServiceApplicationPool" autoStart="true" managedPipelineMode="Integrated">
                <processModel identityType="LocalSystem" idleTimeout="00:00:00" pingingEnabled="true" />
                <recycling logEventOnRecycle="Time, Requests, Schedule, Memory, IsapiUnhealthy, OnDemand, ConfigChange, PrivateMemory">
                    <periodicRestart time="00:00:00">
                        <schedule>
                            <clear />
                        </schedule>
                    </periodicRestart>
                </recycling>
            </add>
            <add name="0d0efe5a69aa4e14b9e9f593b3bb2551" autoStart="true" managedPipelineMode="Integrated">
                <processModel identityType="NetworkService" idleTimeout="00:00:00" pingingEnabled="true" />
                <recycling logEventOnRecycle="Time, Requests, Schedule, Memory, IsapiUnhealthy, OnDemand, ConfigChange, PrivateMemory">
                    <periodicRestart time="00:00:00">
                        <schedule>
                            <clear />
                        </schedule>
                    </periodicRestart>
                </recycling>
            </add>
            <add name="SharePoint Central Administration v4" autoStart="true" managedPipelineMode="Integrated">
                <processModel identityType="NetworkService" loadUserProfile="true" idleTimeout="00:00:00" />
                <recycling logEventOnRecycle="Time, Requests, Schedule, Memory, IsapiUnhealthy, OnDemand, ConfigChange, PrivateMemory">
                    <periodicRestart time="00:00:00">
                        <schedule>
                            <clear />
                            <add value="02:43:00" />
                        </schedule>
                    </periodicRestart>
                </recycling>
                <failure rapidFailProtectionMaxCrashes="10" />
            </add>
            <add name="SharePoint - 80" autoStart="true" managedPipelineMode="Integrated">
                <processModel identityType="NetworkService" loadUserProfile="true" idleTimeout="00:00:00" />
                <recycling logEventOnRecycle="Time, Requests, Schedule, Memory, IsapiUnhealthy, OnDemand, ConfigChange, PrivateMemory">
                    <periodicRestart time="00:00:00">
                        <schedule>
                            <clear />
                            <add value="01:26:00" />
                        </schedule>
                    </periodicRestart>
                </recycling>
                <failure rapidFailProtectionMaxCrashes="10" />
            </add>
            <add name="9da36b17dcf54ae08e904d43467e6c0b" autoStart="true" managedPipelineMode="Integrated">
                <processModel identityType="NetworkService" idleTimeout="00:00:00" pingingEnabled="true" />
                <recycling logEventOnRecycle="Time, Requests, Schedule, Memory, IsapiUnhealthy, OnDemand, ConfigChange, PrivateMemory">
                    <periodicRestart time="00:00:00">
                        <schedule>
                            <clear />
                        </schedule>
                    </periodicRestart>
                </recycling>
            </add>
            <add name="Icp" autoStart="true" managedRuntimeVersion="v4.0" />
            <applicationPoolDefaults enable32BitAppOnWin64="true">
                <processModel identityType="ApplicationPoolIdentity" />
            </applicationPoolDefaults>
        </applicationPools>
share|improve this question

1 Answer 1

Make sure that Application Pool Defaults has the enable32BitAppOnWin64 option set to false.

share|improve this answer
    
Didn't help. If I set one pool to true, all pools have true and vica verse. –  user71541 Jan 16 '12 at 19:17
    
If the option is explicitly set to false in the Application Pool Defaults configuration, it will not change for all, just because you change it for one. Try to copy and paste in the "Application Pools"-section from your applicationHost.config file –  Mathias R. Jessen Jan 16 '12 at 19:20
    
Ok I added the applicationPools section. –  user71541 Jan 16 '12 at 19:31
    
I did set enable32BitAppOnWin64 option to false in Application Pool Defaults. Then I did set enable32BitAppOnWin64 to true on the ASP.NET v 4.0 pool. Then checked back on enable32BitAppOnWin64 on Application Pool Defaults and it was true. This is weird :-) –  user71541 Jan 16 '12 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.