Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Every time I restart my server (Windows Server 2008 R2 Enterprise) the following DCHP events appear with the ID 10020 in my event log. I have a static IPv6 address but this event is still being generated.

I searched on the web and on most of the forums are saying if the IPv6 address is static and is configured, to ignore this warning, but I am not so convinced

Event ID:      10020
Source:        Microsoft-Windows-DHCP-Server
Type:          Warning
Description:
This computer has at least one dynamically assigned IPv6 address. For reliable DHCPv6 server operation you should use only static IPv6 addresses.
share|improve this question
2  
The full event text would be very helpful, rather than us having to Google for it. –  Ben Pilbrow Jan 16 '12 at 19:14
    
I am 99% sure I have pasted the correct event text. Please verify this and correct if necessary. –  Ben Pilbrow Jan 16 '12 at 19:37
    
Thank you Ben, that is the correct event description –  wulffgarr Jan 17 '12 at 8:13

1 Answer 1

Event ID 10020 = This computer has at least one dynamically assigned IPv6 address

Having a static IP assigned in IPv6 does not perclude a dynamic IP address assignment. IPv6 is not simply IPv4 with bigger addresses. Check your local and network configruation again.

share|improve this answer
    
I do not now how to configure exactly. I just added static ipv6 and i thought that will solve the problem. But i see it shows more ipv6 addresses. So i don't know what to do –  wulffgarr Jan 17 '12 at 8:34
    
The other IP must be coming from somewhere, DHCPv6 or Stateless. Sounds like this is a DHCPv6 server, is there another computer that is the DG and has announcements configured? –  Chris S Jan 17 '12 at 13:27
    
There is no other computer that is DG. But is no other way to check the configuration? To see maybe is something wrong, or? –  wulffgarr Jan 18 '12 at 8:44
    
If you cant find it in the configuration you'll have to break out something like Wireshark and see what's going on at the wire. –  Chris S Jan 18 '12 at 13:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.