Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am learning Linux and recently encountered an error upon reboot saying "User's $HOME/.dmrc file is being ignored.." The message went on to say this was preventing the default session from being saved and that the file needed to have 644 permissions. I started some reading on permissions and config files and reinstalled Linux fresh on my VM. I also read various forums that advised users facing similar problems to chmod permissions for this file to 644. However, in the fresh install I see that the default permission for home/.dmrc is 600 (-rw-------). Why is this the case? If it needs to be 644, why would it be set to this on the default install.

share|improve this question
add comment

4 Answers 4

0644 is world readable. Which means that any other user could potentially read your settings.

0600 is only readable by your user. There's no valid reason why a programm run by your user needs privileges more open than 0600 to function correctly.

Are you sure you aren't mixing the permissions up and it actually complains about being 644 rather than 600?

share|improve this answer
    
No, the message specifically said "User's $HOME/.dmrc file is being ignored. This prevents the default session and language from being saved. The file should be owned by the user and have 644 permissions. The user's $HOME directory must be owned by the user and not writable by others" –  user10510 Jul 2 '09 at 15:13
    
GDM, which is what is going to read this file is running as root, so should be able to read that file, unless, you're running with NFS home directories. –  David Pashley Jul 2 '09 at 15:37
add comment

Do you have a home partition and a root partition? If so the file would stay.

LOTS of people complaining of this bug after updates or installing certain soft.

http://ubuntuforums.org/showthread.php?t=91455&page=3

share|improve this answer
    
Yes, I was trying to learn about partitioning and file systems and originally created a temp, root, and swap partition. Now am going to try root, home and swap. I suppose I am confused whether this is a bug or by design for a reason I cannot seem to find in official documentation. Lots of people giving various types of advice across the forums - and yes, I see many people complaining about this issue and while they are able to fix it, I am not seeing any clear explanation of why the permissions are this way to start off with and what creates the snafu after partitioning. –  user10510 Jul 2 '09 at 17:04
    
So if you reloaded on /root your home dir files would stay the same. –  MathewC Jul 2 '09 at 17:33
add comment

Not only do you need to change permissions on the $HOME/.dmrc file, but you will also want to change the home directory permissions to 700.

chmod 644 $HOME/.dmrc

chmod 700 /home/[USER]

share|improve this answer
    
Jeremy, thanks for your answer. Do you know why then the default permissions are set to 600 for $HOME/.dmrc and 755 for /home/[USER] (only writes by groups and others disallowed)? –  user10510 Jul 2 '09 at 17:15
    
When I've seen the error occur, it has usually popped up because the gdm user doesn't have permission to at least read the file (600), it may have been set to 600 by default after assuming that Gnome wasn't installed on the system in an effort to keep the directory private using the least permissive option. –  Jeremy Viet Jul 2 '09 at 19:25
    
@JeremyViet: Thanks, this fixed the issue for me. –  Jonas Oct 14 '11 at 18:06
add comment

i have had this issue ever since i installed mint Gloria 7.

Although I have an inkling why.

Originally i had 2xHD's, on one i had installed jaunty and used it as my main OS, on the other HD i had installed gloria to see how it rolled.

One day one HD failed =sad face=, my main OS.

As i have no clue about grub I struggled to understand if the HD died or the data was corrupted or the os failed.

I couldn't quite just boot into my 2nd HD, so i installed Gloria again, over its original install. all my apps and documents were still there after the gloria was installed.

I didn't see this message as a problem because it only pops up when i log-in, i tend not to shut down the box, unless for maintenance or relocation.

But it would be nice to be able to just login and not get this legend about dmrc file is being ignored, and 644 permissions.

I gave your solution a try jeremy, and maybe in the not too distant future when i reboot and the legend has gone, i will remember to come back and hi5 ya.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.