Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My network setup is very simple: two win7-64 machines connected to a switch. IPv6 enabled for their network interface. No router no outside network no DHCP.

ipconfig report for the computer shows that they obtain a link local ipv6 address:
machineA: Link-local IPv6 Address . . . . . : fe80::7d4a:a8f:2a:e190%10
machineB: Link-local IPv6 Address . . . . . : fe80::2506:6b8e:d161:adcb%11

However I get "Destination host unreachable" error when I ping machineA from machineB using the following syntax: ping fe80::7d4a:a8f:2a:e190 ping fe80::7d4a:a8f:2a:e190%11

Note: when I ping using the IPv4 address using the exact same configuration and the same time I get response.

Edit: this is the interface info:

Interface List
11...78 2b cb 97 e0 a9 ......Intel(R) 82579LM Gigabit Network Connection
share|improve this question
    
You don't include the interface spec when pinging (the part including and after the "%"). Firewalls? Security Suite Software? –  Chris S Jan 17 '12 at 14:03
1  
@ChrisS: no, you do include the interface spec when pinging link-local addresses. Not including it will definitely not work. Dunno about the numeric interface identifiers, I'm used to using the name of the interface, not a number, but the OP is using MS Windows, maybe numbers are correct under MS Windows. Also, is there a separate ping6 command under MS Windows like there is under Linux? –  Celada Jan 21 '12 at 16:36
add comment

1 Answer

up vote 3 down vote accepted

In the Windows world, that number after the % sign in your link-local addresses is commonly referred to as a "zone ID." It's all the same though. In your scenario - two Windows 7 nodes connected by a switch - you do not need to include it. It is optional. The ping will succeed whether you include the zone ID or not.

Here are two remote sessions side by side, pinging one another. Two Win2k8r2 nodes on the same switch, just like your scenario: (Open in new window if the image is not large enough)

enter image description here

There can only be two things stopping you at this point that I can think of: Either you have a really gimpy switch that won't switch IPv6 packets, or (most likely) you have ICMPv6 blocked by the Windows Firewall on your clients. This is the default configuration of Windows 7 and I did not read you mention the Windows Firewall, so I'd take a look there.

share|improve this answer
    
It indeed was a firewall blocking only IPv6 transmission. Norton antivirus which comes with some kind of network protection is installed on our machines in the office. Once I disabled it, ping was allowed. Thanks for the help and sorry for the late response –  galbarm Feb 27 '12 at 8:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.