Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Normally this is not grayed out but on this windows server 2003 it is:

enter image description here

It results in disconnected sessions being terminated after 1 minute.

Can I set this in the registry to "never terminate disconnected sessions"?

(The dropdown box was disabled after installing and uninstalling some 3rd party software, I have no hope of fixing the dialog)


Solution:

See also: http://www.sevenforums.com/tutorials/118889-remote-desktop-set-time-limit-idle-sessions.html

Start the Group Policy Editor:

c:\> gpedit.msc

From http://technet.microsoft.com/en-us/library/cc754272.aspx :

You can also configure timeout and reconnection settings by applying the following Group Policy settings:

Set time limit for disconnected sessions

Set time limit for active but idle Remote Desktop Services sessions

Set time limit for active Remote Desktop Services sessions

Terminate session when time limits are reached

These Group Policy settings are located in the following locations:

Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

These Group Policy settings can be configured by using either the Local Group Policy Editor or the Group Policy Management Console (GPMC).

These Group Policy settings will take precedence over the settings configured in Remote Desktop Session Host Configuration. If both the Computer Configuration and the User Configuration policy settings are configured, the Computer Configuration policy settings take precedence.

enter image description here

share|improve this question

1 Answer 1

up vote 1 down vote accepted

If the setting is unavailable on the properties of the RDP protocol then it's being set via Group Policy. You'll need to check the GPO's that apply to the server in question and configure the setting there.

share|improve this answer
1  
@mit - Yes, utilize RSOP to find the policy where it's coming from. –  Vick Vega Jan 17 '12 at 18:09
    
Thank you, this is the solution. Although I could not find anything configured in the GPO I could set my desired value "never terminate disconnected sessions" there and it is also reflected in the grayed out RDP settings dialog then, but still grayed out, but that's not a problem anymore now :) –  mit Jan 17 '12 at 23:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.