Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

What could I be doing wrong here?

  • Added Everyone to local security settings (testing purposes only)
  • Forced the policy to update with gpupdate /force
  • ran whoami /priv

The permission I added is not showing under whoami /priv? Why?

In case it is relevant I'm following the instructions from here (and yes I restarted sql server)

enter image description here

share|improve this question
1  
have you logged off and back on? Also does the right remain? Perhaps a domain GP is overwriting your setting –  Paul Ackerman Jan 17 '12 at 20:26
    
@PaulAckerman - I've restarted the computer, and SeManageVolumePrivilege still does not show up at all under whoami. I've done the same steps on my machine (not on a domain). Same issue. When I run powershell as administrator it shows SeManageVolumePrivilege as disabled, which in itself is confusing to me. –  O.O Jan 17 '12 at 20:28

1 Answer 1

The "State" column of the whoami.exe utility has two values - either Enabled or Disabled. However, this does not mean that the user does or does not have access to this privilege. If the privilege is listed at all, then that user has it.

What enabled and disabled mean in this context is something along the lines of "is the privilege currently being used in this process?"

Even if it says disabled using the whoami utility, that doesn't mean that the currently logged on user is not able to request it and use it.

Yeah, it is confusing.

What will happen if a "regular user" tries to do something that requires that SeManageVolumePrivilege privilege, he/she will be given a UAC prompt, after which he/she will have that SeManageVolumePrivilege privilege. Even if the UAC prompt is suppressed, there will still be some code executed that grants the user that privilege when necessary.

share|improve this answer
    
Interesting. It shows up like you say for an Administrator, but it doesn't show in the list at all for the a user. –  O.O Jan 17 '12 at 21:46
    
Well, the only way to know for sure is to actually try to perform a volume management task with a regular user! :) –  Ryan Ries Jan 17 '12 at 21:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.