Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're in the process of trying to change the desktops icons on all our client machines to the "Classic View" size. Microsoft says there's no way to do this on Server 2008 R2 using GPO/GPP. We're hoping if we can find the right registry key, we'll be able to push that change out to the thin clients in the field when they log in. Otherwise we have to make the changes to the profiles and recreate them manually, which is not a happy thought. Is there a registry key we're missing somewhere or have we just overlooked a better solution?

We've played around with the HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics key, but the changes don't seem to do anything. The grid for the icons changes a little bit, but the icons themselves stay the same.

Seems like no one knows the answer to this question, so I'm hoping you fine folks might be able to help. Any input is welcome. Thanks in advance.

share|improve this question
    
What do you mean by "Classic View" size? Are you trying to change the theme or just the size of the icons on the desktop? –  newmanth Jan 18 '12 at 19:29
    
Just the size of the icons.We're trying to make the icons smaller, the same size as the "Classic View" icons. Sorry that wasn't clear. –  wacokid Jan 18 '12 at 19:39
    
You changed the ShellIconSize value and had the current user log off and back on? –  Mathias R. Jessen Jan 18 '12 at 19:44
    
That doesn't work in Server 2008 for some reason. I've not been able to find any documented reason why it doesn't work, just that it doesn't work anymore. –  wacokid Jan 18 '12 at 20:51
add comment

3 Answers

up vote 3 down vote accepted

You can't do that since DPI is a user based setting. Even if you were to find the magic set of keys, it's not persistent and depends on the display device. In a nutshell don't do this even if you find the magic keys. I suspect that trying to change this could cause display driver crashes as they are expecting certain ranges of numbers (and I think it should reset as soon as it detects that the display device doesn't match the numbers you've set).

Perhaps a better thing is to ask is what are you trying to accomplish by changing the size of the icons?

share|improve this answer
    
Since you can control + scroll wheel on the desktop to resize the icons, we found/created a little start up program to send those commands to the OS. Seems to be the safest way of doing it. Thanks for the help! –  wacokid Jan 23 '12 at 22:19
add comment

I'm assuming you want to change the taskbar to look more like Windows XP. To do this change via the registry, modify the following keys:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\TaskbarSmallIcons = 1

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\TaskbarGlomLevel = 1

A few caveats:

  1. This is a per user setting, so it has to be changed while the user is logged in. This can be done easily via a login script.
  2. The change won't take effect until the user's next login.
  3. To set this as the default view for all new logins, you'll need to customize the default user profile for the machine. Instructions here.
share|improve this answer
    
We're trying to change the desktop icons, not the taskbar. –  wacokid Jan 18 '12 at 19:55
    
Oh, sorry about that... my bad. So, you're trying to make the desktop icons smaller? –  newmanth Jan 18 '12 at 19:58
    
Yes... "Ours is not to reason why. Ours is but to do and die." –  wacokid Jan 18 '12 at 20:55
    
So... I think that the correct value to set is HKCU\Software\Microsoft\Widnows\Shell\Bags\1\Desktop\IconSize (change to 0x20). BUT, I can't seem to get it to take on my machine. Booo :( Perhaps you'll have better luck. –  newmanth Jan 18 '12 at 23:16
add comment

I believe the correct key is HKCU\Control Panel\Desktop\WindowMetrics\Shell Icon Size.

You will need to log off and log back on (or restart), to take effect.

share|improve this answer
    
As mentioned in other responses, this does not work on Server 2008. Thanks. –  wacokid Jan 23 '12 at 18:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.