Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

when accessing: -->

I have tried this:

 http {
    port_in_redirect off;

Any ideas?

share|improve this question
Can you provide your configuration? Are you proxying to another service behind nginx? – Shane Madden Jan 18 '12 at 20:46
I believe we are are proxying to apache. Which configuration files do you want? – Chris Muench Jan 18 '12 at 21:37
The nginx configuration file that defines the server block which contains the proxy_pass directive. What you're probably going to need will be a proxy_redirect directive - seeing your config should confirm. – Shane Madden Jan 18 '12 at 22:22
Note that some browsers cache redirects so when changing port_in_redirect from on to off you may need to restart it. – emersion Apr 11 at 21:30

I just ran into the same problem and port_in_redirect off; actually worked for me, just make sure you use it inside the server {} block.

server {
  listen 8080;

  port_in_redirect off;
  autoindex on;

  location / {
    root /var/www/;
    index index.html;
share|improve this answer
Or even use port_in_redirect inside location. – wqw May 19 at 12:49

This should fix problem. Add proxy_redirect directive right after proxy_pass directive


share|improve this answer

I had the same problem with my nginx + Apache setup. Apache seems to be redirecting to it's own port (running on 8080), while nginx is on port 80.

In my setup, this made infinite redirect loop for normal urls:

proxy_set_header Host $host:80; # Force port 80

Instead bind the returning data to port 80, like this:

proxy_bind $host:80; # Bind to port 80

Here is my nginx server block:

server {
    listen 80;
    listen [::]:80 ipv6only=on;

    server_name _; # Wildcard server

    location / {
        proxy_bind $host:80; # Bind to port 80 << THIS IS THE MAGIC
        proxy_pass http://localhost:8080;
        proxy_set_header Host            $host; # Pass host header
        proxy_set_header X-Real-IP       $remote_addr; # Preserve client IP
        proxy_set_header X-Forwarded-For $remote_addr;

With this wildcard setup, all requests nginx does not have a server block for is passed on to Apache.

share|improve this answer

syntax: port_in_redirect [ on|off ]
default: port_in_redirect on
context: http, server, location

Hope this is what you are looking for.

share|improve this answer
I have tried this in the http context with no luck – Chris Muench Jan 18 '12 at 20:18

I had a similar problem.

Maybe you should use directive proxy_set_header to set the headers' host and location. In my configuration I added proxy_set_header Location $host:80; and all the requests return port 80 now.

share|improve this answer
I believe this will break redirects beyond "/" - every redirect would point to $host:80 – perrierism Aug 24 '15 at 17:48

This issue is caused by Nginx auto translate relative path to absolute path, right?
There is a way to tell Nginx not translate, you add a space before slash: ngx.redirect(" /foo")

share|improve this answer
Please note that this is a question from 3 years ago. – Deer Hunter Apr 9 '15 at 1:07

In case anyone else was having this issue - the article here: solved the problem for me.

I had to add an extra header in the proxy.

Make sure you have the Host set to $http_host and also that you have set the X-Forwarded-Host to $http_host like below:

proxy_redirect off; proxy_set_header Host $http_host; # <-- make sure this is $http_host proxy_set_header X-Forwarded-Host $http_host; # <-- make sure you set this proxy_set_header X-Real-IP $remote_addr; proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; proxy_connect_timeout 90; proxy_send_timeout 90; proxy_read_timeout 90; proxy_buffer_size 16k; proxy_buffers 32 8k; proxy_busy_buffers_size 64k;

share|improve this answer

I would recommend instead adding this to your server block:

rewrite /wp-admin$ $scheme://$host$uri/ permanent;

This was when you go to it will go to rather than going to and if you are on CloudFlare DNS for instance it will say the site is down.

I'm using Ubuntu, Nginx and Varnish and this works perfectly now rather than disabling port_in_redirect.

To add, be sure to to restart nginx after:

sudo service nginx restart
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.