Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to install mysql 5.6 on my ubuntu machine for development reasons (the newest version contains features that I need to incorporate into some web projects). But I am having some issues. I've been following this tutorial which is not specific for version 5.6 but I figured it would be about the same: http://www.ovaistariq.net/490/a-step-by-step-guide-to-upgrading-to-mysql-5-5/

I'm not sure if i'm setting up my /etc/my.cnf file properly. Here is what I have:

# Example MySQL config file for large systems.
#
# This is for a large system with memory = 512M where the system runs mainly
# MySQL.
#
# MySQL programs look for option files in a set of
# locations which depend on the deployment platform.

# You can copy this option file to one of those
# locations. For information about these locations, see:
# http://dev.mysql.com/doc/mysql/en/option-files.html
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password   = your_password
port        = 3306
socket      = /var/run/mysqld/mysqld.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port        = 3306
socket      = /var/run/mysqld/mysqld.sock
skip-external-locking
key_buffer_size = 256M
max_allowed_packet = 1M
table_open_cache = 256
sort_buffer_size = 1M
read_buffer_size = 1M
read_rnd_buffer_size = 4M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size= 16M
pid_file    = /usr/local/mysql/data/dev.pid
basedir         = /usr/local/mysql
datadir         = /usr/local/mysql/data
tmpdir          = /tmp
log_error       = /var/log/mysql/error.log
user        = mysql

# Try number of CPU's*2 for thread_concurrency
thread_concurrency = 8

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
# 
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
log-bin=mysql-bin

# binary logging format - mixed recommended
binlog_format=mixed

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id   = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /usr/local/mysql/data
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /usr/local/mysql/data
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 256M
#innodb_additional_mem_pool_size = 20M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 64M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[myisamchk]
key_buffer_size = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

When I try to run

mysqld --skip-grant-tables --user=mysql

I get this error:

The program 'mysqld' can be found in the following packages:
 * mysql-server-core-5.1
 * mysql-cluster-server-5.1
Try: sudo apt-get install <selected package>

When i try to stop the server, I get this:

* MySQL server PID file could not be found!

When I try to start:

Starting MySQL
.. * The server quit without updating PID file (/usr/local/mysql/data/dev.pid).

I am assuming I am not editing the my.cnf file properly, but i'm completely lost. Otherwise I have followed the instructions perfectly and I have made sure that the previous mysql 5.1 version was completely removed from the system.

share|improve this question

migrated from stackoverflow.com Jan 18 '12 at 21:46

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 1 down vote accepted

For the mysqld error, you may need to make sure that the binaries are in your $PATH. Try checking using which mysqld.

If it is not on your path, you should add it to your profile (if you're using bash, this will probably be ~/.bash_profile):

export PATH=/path/to/mysql/bin:$PATH

As for the PID error, you might check /var/log/mysql/error.log to see if it gives you any hints as to what's wrong, but I have a feeling that it may be that the user the MySQL server is running under does not have permissions to write to the PID file, so make sure that it's owned by the mysql user (or the equivalent for your distro).

share|improve this answer
    
The path was exported. I am upgrading from version 5.1 to 5.6 so I already had an existing mysql user. Is it possible that I had previously set a password to the mysql user and its not working because I am not supplying a password? Any way to check that and change the password if necessary? –  ryandlf Jan 18 '12 at 16:29

The problem sounds like you are using the wrong PATH variable in regards to your mysql installation. Maybe try using the full path of your mysqld-binary.

I have also written a post on how to upgrade mysql provided with ubuntu 12.04. Have a look at it on http://www.peterchen.net/2013/02/20/en-how-to-install-mysql-5-6-on-ubuntu-12-04-precise/. Hope this will help you as it covers mysql 5.6 and not the old mysql 5.5.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.