Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having troubles with my nagios getting it to give me feedback about the ammount of free/used diskspace on the clients it's monitoring.

at the moment, it runs the default check_all_disks!20%!10% and one check_disk!20%!10%!/

Only thing it shows me on the "Service Detail" overview is: Disk OK

It would be very nice to have either the percentage or free/used in the service detail overview.

Is this possible?

If I click the service check - it shows me some numbers in Performance Data. What's this supposed to be?

Edit: Seems like when updating to the newest version of Nagios Core - the information I was looking for, gets displayed.

share|improve this question
I am getting full details for the check_disk commands. What is your nagios version? Can you post the defined check command and the plugin version? – Khaled Jan 19 '12 at 10:38
It's reporting to be Nagios® Core™ 3.2.0 - How do I check the plugins version? – xstnc Jan 19 '12 at 10:42
You can use check_disk --help. You may need to specify the full path to check_disk such as /usr/lib/nagios/plugins/check_disk. – Khaled Jan 19 '12 at 10:49
Plugins: check_disk v1.4.14 (nagios-plugins 1.4.14) – xstnc Jan 19 '12 at 10:55
Same of mine! What do you get if you run the command manually like /usr/lib/nagios/plugin/check_disk -w 20% -c 10%? – Khaled Jan 19 '12 at 11:12
up vote 2 down vote accepted

After upgrading the nagios core to the newest version - it reports free disk space just the way I wanted!

share|improve this answer

I am using this check_snmp_storage, It's mandatory for it to work that the servers you are querying have enabled snmp, but it will give you percentage reports for every mounted partition on your system.

Really nice and effortless

Also on the snmdp.conf i add: disk / 10%

To have a warning level set to default (in case you monitor it with cacti)

share|improve this answer
This is definitly a workaround worth taking a note of! Will consider it if all else fails :) – xstnc Jan 19 '12 at 12:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.