Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem setting owa up on a testmilieu for exchange 2003! Actually I didn't install exchange 2003, I just got the case about getting owa to function and at the same time I don't know that much about exchange 2003.

When I hit this in the browser (on exchange server): http://localhost/exchange, I should get a loginform, right? I just keep getting 404 - page not found!

I get the loginform when I hit: http://localhost/exchweb/bin/auth/owalogon.asp?url=https://localhost/exchange&reason=0, but this redirects me to http://localhost/exchweb/bin/auth/owaauth.dll ???

This smells like a bad installation, or is it just some wsettings I have missed?

Any help is appriciated...

/Finn.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Actually the problem wasn't that technical and I'm a bit embarrased to admit that I discovered that asp.net was set to .net 4.0! I changed that to .net 2.0 and resat the virtual directories and voila!

Cheers for the help...

/Finn

share|improve this answer
add comment

Actually my Exchange 2003 reports itself as https://external.domain.com/exchweb/bin/auth/owalogon.asp?url=https://external.domain.com/exchange&reason=0 after i type in https://external.domain.com so your localhost query looks ok to me. What kind of problem are you having? That when you type http://localhost/exchange it doesn't work but when you type http://localhost/exchweb/bin/auth/owalogon.asp?url=https://localhost/exchange&reason=0 it does work ? Also have you tried using https://localhost/exchange?

Take a look at your IIS it's where it's set up. You should be checking the ports, ip iis is working on and http/https settings.

If you're IIS is in bad shape and you want to reinstall it (as per your comment) take a look at this articles:

As per quote from the first article it's not really a walk in the park:

Apparently when you remove IIS you have also removed some additional configuration parameters that exchange has added to the IIS Metabase and you must follow the 6 steps below to relink the attributes when you install IIS again.

1. Back Up Data
2. Dismount the Mailbox and the Public Information Store
3. Stop Exchange Services and Remove IIS
4. Reinstall Internet Information Service and Reapply Service Packs
5. Reinstall Exchange Server
6. Restore the Original Exchange Information Store

So think hard before reinstalling IIS. I guess it's "simpler" to try to fix it.

share|improve this answer
    
My problem is that localhost/exchange and localhost/exchange does not work (of course with ssl turned on for the https), I only get "Internet Explorer cannot display the webpage" for both of them. –  Finn Christensen Jan 20 '12 at 9:53
    
How does it look in IIS? –  MadBoy Jan 20 '12 at 10:05
    
I'm a little bit confused, my iis 6 does not look healthy the way I remembered it to be. And it does not look like the system recognizes it! I'll try reinstall and get back to you, might be over the weekend! Thanks for now, MadBoy. I'll keep you updated! –  Finn Christensen Jan 20 '12 at 11:27
    
Thanks a lot, MadBoy! I'll check it out. I think I will setup a virtual box in the weekend, and install everything from the bottom, just to learn about it. And then see how I can get around it in my testmilieu! Cheers... –  Finn Christensen Jan 20 '12 at 13:03
    
Hmm- Sorry for the delay in answering! I didn't make a clean install on virtual box, because it's too timeconsuming - you have to setup a dc and everything just to install exchange 2003. Instead I have tried to investigate a little bit, as madboy sugested. I have done a reset on the virtual directories in IIS, by editing the metabase.xml settings. But this didn't do anything. The reason why I think my IIS is not healthy is that I recon that one used to see the IIS ver.no. when hitting help/about IIS...but it doesn't. I'll get back with some more update... –  Finn Christensen Jan 24 '12 at 9:54
show 9 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.