Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Debian installation with Mailman using exim as MTA.

I can create mailing lists and receive emails from mailinglist server. But when i try to send an email to the ML address it is refused with the following error:

H=(...) F=(user@email.dom) rejected RCPT relay not permitted

where list@mailinglist.dom is my mailing list (just for example).

I looked everywhere on google but actually none of the solution proposed help me. I'm trying to use virtual domains. The mailing list seems correctly configured (i can create them, and manage them from the web interface, and as i said above receive mail from them). The problme seems to be in Exim server configuration.

This is the tutorial that i followed: http://www.debian-administration.org/article/Mailman_and_Exim4 I added the folder: /etc/exim4/virtual with one file: mailinglist.dom, and it contents is:

list: list@mailinglist.dom

I modified the /etc/exim4/conf.d/main/01_exim4-configlistmacrodefs

domainlist local_domains = @:localhost:dsearch;/etc/exim4/virtual

And added the following file: /etc/exim4/conf.d/router/350_exim4-config_vdom_aliases with:

vdom_aliases:
  driver = redirect
  allow_defer
  allow_fail
  domains = dsearch;/etc/exim4/virtual
  data = ${expand:${lookup{$local_part}lsearch*@{/etc/exim4/virtual/$domain}}}
  retry_use_local_part
  pipe_transport   = address_pipe
  file_transport   = address_file
  no_more

this is the other tutorial that i followed: http://www.debian-administration.org/articles/140

Now i spent all day trying to solve that problem without success. Can you help me?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Finally i managed to solve that problem. Here the steps:

  1. I launched dpkg-reconfigure exim4-config
  2. I used default settings except for:
    • System mail name: I used the domain name (domain.ext format as suggested in the box)
    • Other destinations for which mail is accepted: (Here I inserted all the domains that must be treated as local domain. With the format: mail.domain.ext)

I restarted exim, and now everything works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.