Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was just hoping to step through a couple queries to see how the temp tables are interacting and I'm getting this message.

The windows firewall on this machine is currently blocking remote debugging. Remote debugging requires that the debugging be allowed to receive information from the network.Remote debugging also requires DCOM (TCP port 135) and IPSEC (UDP 4500/UDP500) be unblocked

Even when I walked over to the actual machine and tried running the debugger, I'm still getting the same message. Am I missing something or does the debugger try to run remotely even from the local machine? Since this was meant to be just a quick check, I don't need instructions on how to open up the firewall, just hoping there is a way to run the debugger locally instead.

share|improve this question

I think this article address your need... it clearly states if you running it locally on the same box, no need to muck with the firewall.

There are no configuration requirements to run the Transact-SQL debugger when SQL Server Management Studio is running on the same computer as the instance of the SQL Server Database Engine. However, to run the Transact-SQL debugger when SQL Server Management Studio is running on a different computer from the instance of the Database Engine, you must enable program and port exceptions on both computers.

share|improve this answer
yeah, I didn't think there would be any requirements for running on the local machine since it shouldn't even be trying to jump outside of the firewall in the first place. I'll go back and make sure I'm using "localhost" instead of the IP and see if that helps at all. – Mercurybullet Jan 21 '12 at 2:17
It should. If you use the local IP then to my knowledge it DOES Loop through the firewall on purpose ;) – TomTom Aug 6 '14 at 10:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.