Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just set up a home server to host my site. I can access the site fine from any network apart from my home network.

I thought it might be an issue with DNS, so I decided to ping my domain from my laptop (on my home network), and got the following:

$ ping alexcoplan.co.uk
PING alexcoplan.co.uk (88.108.252.160): 56 data bytes
Request timeout
Request timeout
etc...

Which is really strange, because the domain is resolving to the wrong IP.

I knew that the site was working, because I accessed it on my phone via the cellular network and it loaded fine. Just to double check, I ran terminal emulator on my phone, and pinged my site, and got the following:

$ ping alexcoplan.co.uk
PING alexcoplan.co.uk (88.111.7.117): 56 data bytes

Which is the correct IP.

So that begs the question, why is my domain resolving incorrectly inside the network?

share|improve this question
    
Server Fault is for Professional System Administrators only. This question is well suited to Super User however and will be migrated there automatically. Start troubleshooting by: Do a nslookup alexcoplan.co.uk and see what DNS server you're getting the wrong result from. Could the wrong IP be a cached entry (ie was it this IP at one point in the recent past)? Are you using a router that allows for hairpin connections, ie can you type the IP address into your browser on your laptop and get the websites (this doesn't affect the wrong DNS thing). Is the hostname of any of the computers alexcoplan.co.uk? –  Chris S Jan 22 '12 at 15:04
add comment

1 Answer

up vote 3 down vote accepted

You have to start debugging at the computer where you get the wrong IP, to try to figure out where the erroneous IP lookup comes from. First check your /etc/hosts file to see if you happen to have any entries in there pointing to 88.108.252.160 (seems to be a DSL IP (your home IP?) 88-108-252-160.dynamic.dsl.as9105.com.).

Just to ask too, make sure the computer you ping from isn't NAMED alexcoplan.co.uk! :)

Next step would be to check where /etc/resolv.conf points to and ask those nameservers for the IP for alexcoplan.co.uk to see if they somehow have cached the wrong IP.

If nothing seem to work you can try configuring your computer to use Googles public DNS as your nameservers for a while, to outrule that there is something wrong with your current configured nameservers. Googles recursive DNS servers that you can use is 8.8.8.8 and 8.8.4.4. Read more about them here:
http://code.google.com/speed/public-dns/

share|improve this answer
    
thanks - my first step was indeed to check the hosts file. - the server isn't named that. - do you mean that I should add the nameservers for my domain to my resolv.conf file? –  Alex Coplan Jan 22 '12 at 15:18
1  
google public dns does solve the issue though! –  Alex Coplan Jan 22 '12 at 15:51
    
Then for some reason the previous nameservers you had configured in /etc/resolv.conf has the wrong IP cached for your domain. Hard to say why, could be anything from a recent update (following your SOA serial last update was October 28th though so unless you're not updating that one properly its unlikely), worst case its someone who managed to "DNS poison" those nameservers to try to abuse somehow. Use googles DNS for a while and then try your old ones tomorrow to see if the bad DNS records have expired! Glad it worked. :) –  Mattias Ahnberg Jan 22 '12 at 17:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.