Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have problem with curlftpfs. When i mount it manualy everything works, but when I try to autmount via /etc/fstab, after reboot system stops on error 'Couldn't resolve host [my host name].

Line I added to fstab:

curlftpfs#[username with @ escaped to %40]:[password]@[host] /media/[my dir] fuse allow_other,uid=0,gid=0 0 0

Manual command, that works:

curlftpfs [same username]:[same pass]@[same host] /media[same dir]
share|improve this question
    
Did you try using IP instead of hostname in fstab entry? –  Khaled Jan 22 '12 at 15:54
    
Same error occurs. Couldn't resolve [host domain]. Not ip - but domain is mentioned as before. Does this maybe occur because of the @ in username? I can't get a username without this character... –  Luigi Jan 22 '12 at 16:14
    
No - that is not the problem. I tried with diffrent ftp, without @ in username. This is a server in cloud, maybe this has something to do with netowrking at the time fstab launches? –  Luigi Jan 22 '12 at 16:39

1 Answer 1

up vote 1 down vote accepted

Adding _netdev requires network to be available before the mount. This is why your manual mount always works, but during a reboot the network has to be available before trying to mount a remote host.

Try this

curlftpfs#[username]:[password]@[host] /media/[my dir] fuse allow_other,uid=0,gid=0,_netdev 0 0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.