Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm currently at a schools network and can't change anything in the routers configuration but I still want to be able to run a web server. I've scanned the router for some open ports and only found out that 8080 is the only open and the router reponds with "net::ERR_EMPTY_RESPONSE" when I try access it.

Is there any solution to my problem?

share|improve this question

closed as off topic by MDMarra, SvW, Chris S, voretaq7, John Gardeniers Jan 23 '12 at 1:10

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
One solution would be speaking with the school's network administrator and discussing your options. –  jscott Jan 23 '12 at 0:50
    
@jscott, yeah, that is a solution but a later one because it's the middle of the night here and I need a solution quite fast. But thanks for mentioning it. –  Victor Bjelkholm Jan 23 '12 at 1:03
    
How can my question be off topic? –  Victor Bjelkholm Jan 23 '12 at 1:25
add comment

1 Answer

Probably not directly. I.e. you're probably not going to be able to stand up a local web server and convince the router to send incoming requests to it.

However, it might be possible to work around the router by, say, creating an SSH connection to some cloud-based server and have the server forward incoming HTTP traffic to your local machine. I've done exactly that for web server development/debugging when the web server absolutely has to be reachable publicly.

A tool that helps with that (at least for development work) is localtunnel.

More of the gritty details: http://souptonuts.sourceforge.net/sshtips.htm

share|improve this answer
    
Thanks, I will look into this! –  Victor Bjelkholm Jan 23 '12 at 0:59
    
It worked very good. However, this feels like a temporary solution. Is there any more permanent fix for this problem? –  Victor Bjelkholm Jan 23 '12 at 1:26
    
@Victor, I don't know of any more permanent solution. Other than working with the network admins to get the router to permanently forward certain traffic to your web server. –  sblom Jan 23 '12 at 1:42
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.